fzoj 1320 Ones(动态规划:水题)

 Problem 1320 Ones

Accept: 567    Submit: 1996
Time Limit: 1000 mSec    Memory Limit : 32768 KB

 Problem Description

Given a positive integer N (0<=N<=10000), you are to find an expression equals to N using only 1,+,*,(,). 1 should not appear continuously, i.e. 11+1 is not allowed.

 Input

There are multiple test cases. Each case contains only one line containing a integer N

 Output

For each case, output the minimal number of 1s you need to get N.

 Sample Input

210

 Sample Output

27

 Source

chenyan

给出一个数,找到一个仅由‘1’, ‘*',‘(’,‘)’构成的等式

输出最少需要一个1


很水的一道题,重新开始刷我的DP

状态转移方程为:dp[i] = min(dp[j]+dp[i/j]+dp[i%j])

代码如下:

#include <cstdio>
#include <iostream>
#include <algorithm>
#define MAXN 10010
using namespace std;

int dp[MAXN];

void init(int n) {
    for(int i=1; i<=n; ++i) {
        dp[i] = i;
    }
    dp[0] = 0;
    for(int i=1; i<=n; ++i) {
        for(int j=1; j<=i; ++j) {
            dp[i] = min(dp[i%j]+dp[j]+dp[i/j], dp[i]);
        }
    }
}

int main(void) {
    init(10010);
    int n;
    while(scanf("%d", &n) != EOF) {
        printf("%d\n", dp[n]);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值