UVA 1330 - City Game(扫描方法 | 单调栈维护)

Bob is a strategy game programming specialist. In his new city building game the gaming environment is as follows: a city is built up by areas, in which there are streets, trees, factories and buildings. There is still some space in the area that is unoccupied. The strategic task of his game is to win as much rent money from these free spaces. To win rent money you must erect buildings, that can only be rectangular, as long and wide as you can. Bob is trying to find a way to build the biggest possible building in each area. But he comes across some problems � he is not allowed to destroy already existing buildings, trees, factories and streets in the area he is building in.

Each area has its width and length. The area is divided into a grid of equal square units. The rent paid for each unit on which you're building stands is 3$.

Your task is to help Bob solve this problem. The whole city is divided into K areas. Each one of the areas is rectangular and has a different grid size with its own length M and width N. The existing occupied units are marked with the symbol R. The unoccupied units are marked with the symbol F.

Input 

The first line of the input file contains an integer K � determining the number of datasets. Next lines contain the area descriptions. One description is defined in the following way: The first line contains two integers-area length M<=1000 and width N<=1000, separated by a blank space. The next M lines contain N symbols that mark the reserved or free grid units, separated by a blank space. The symbols used are:
R � reserved unit
F � free unit
In the end of each area description there is a separating line.

Output 

For each data set in the input file print on a separate line, on the standard output, the integer that represents the profit obtained by erecting the largest building in the area encoded by the data set.

Sample Input 

2
5 6
R F F F F F
F F F F F F
R R R F F F
F F F F F F
F F F F F F

5 5
R R R R R
R R R R R
R R R R R
R R R R R
R R R R R

Sample Output 

45
0

题意:R为被占位置,F为空位,求出最大子空矩阵大小*3.

思路:1、悬线法,记录每个位置的悬线能到达的左边和右边最远位置。然后维护面积最大值。

    2、单调栈维护,对于每个位置,枚举的时候把从左往右依次入栈,维护栈递增,如果遇到冲突情况,就把前面不递增的计算完出栈。注意全部入栈完毕之后要把栈中元素弹出计算。

代码:

悬线法:

#include <stdio.h>
#include <string.h>

const int N = 1005;
int max(int a, int b) {return a>b?a:b;}
int min(int a, int b) {return a<b?a:b;}

int t, n, m, up[N][N], l[N], r[N];

void init() {
	scanf("%d%d", &n, &m);
	for (int i = 1; i <= n; i++)
		for (int j = 1; j <= m; j++) {
			char c = getchar();
			while(c != 'R' && c != 'F') c = getchar();
			if (c == 'R') up[i][j] = 0;
			else up[i][j] = up[i - 1][j] + 1;
		}
}

int solve() {
	int ans = 0, j;
	for (int i = 1; i <= n; i++) {
		up[i][0] = up[i][m + 1] = -1;
		for (j = 1; j <= m; j++)
			l[j] = r[j] = j;
		for (j = 1; j <= m; j++)
			while (up[i][j] <= up[i][l[j] - 1])
				l[j] = l[j] - 1;
		for (j = m; j >= 1; j--) {
			while (up[i][j] <= up[i][r[j] + 1])
				r[j] = r[j] + 1;
			ans = max(ans, up[i][j] * (r[j] - l[j] + 1));
		}
	}
	return ans * 3;
}

int main() {
	scanf("%d", &t);
	while (t--) {
		init();
		printf("%d\n", solve());
	}
	return 0;
}

单调栈维护:

#include <stdio.h>
#include <string.h>
#include <stack>
using namespace std;
#define INF 0x3f3f3f3f
const int N = 1005;

int max(int a, int b) {return a>b?a:b;}
int min(int a, int b) {return a<b?a:b;}
int t, n, m, sum[N][N];
char c;

void init() {
	scanf("%d%d%*c", &n, &m);
	for (int i = 1; i <= n; i++) {
		for (int j = 1; j <= m; j++) {
			c = getchar();
			while (c != 'F' && c != 'R') c = getchar();
			if (c == 'R') sum[i][j] = 0;
			else sum[i][j] = sum[i - 1][j] + 1;
		}
	}
}

int solve() {
	int ans = 0;
	for (int i = 1; i <= n; i++) {
		sum[i][m + 1] = -1;
		stack<int> st;
		for (int j = 1; j <= m + 1; j++) {
			if (st.empty() || sum[i][j] > sum[i][st.top()])
				st.push(j);
			else if (sum[i][j] < sum[i][st.top()]) {
				int pos;
				while (!st.empty() && sum[i][j] < sum[i][st.top()]) {
					ans = max(ans, (j - st.top()) * sum[i][st.top()]);
					pos = st.top();
					st.pop();
				}
				st.push(pos);
				sum[i][pos] = sum[i][j];
			}
		}
	}
	return ans * 3;
}

int main() {
	scanf("%d%", &t);
	while (t--) {
		init();
		printf("%d\n", solve());
	}
	return 0;
}


  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值