ZOJ - 1847 The Trip(奇葩诡异坑题)

Time Limit: 2000MS Memory Limit: 65536KB 64bit IO Format: %lld & %llu

 Status

Description

A number of students are members of a club that travels annually to exotic locations. Their destinations in the past have included Indianapolis, Phoenix, Nashville, Philadelphia, San Jose, and Atlanta. This spring they are planning a trip to Eindhoven.  

The group agrees in advance to share expenses equally, but it is not practical to have them share every expense as it occurs. So individuals in the group pay for particular things, like meals, hotels, taxi rides, plane tickets, etc. After the trip, each student's expenses are tallied and money is exchanged so that the net cost to each is the same, to within one cent. In the past, this money exchange has been tedious and time consuming. Your job is to compute, from a list of expenses, the minimum amount of money that must change hands in order to equalize (within a cent) all the students' costs.


Input

Standard input will contain the information for several trips. The information for each trip consists of a line containing a positive integer, n, the number of students on the trip, followed by n lines of input, each containing the amount, in dollars and cents, spent by a student. There are no more than 1000 students and no student spent more than $10,000.00. A single line containing 0 follows the information for the last trip.


Output

For each trip, output a line stating the total amount of money, in dollars and cents, that must be exchanged to equalize the students' costs.


Sample Input 

3
10.00
20.00
30.00
4
15.00
15.01
3.00
3.01
0

Sample Output

$10.00
$11.99

Source

University of Waterloo Local Contest 1999.01.31
 
 
 
 
分析:
个人感觉这种题没什么意思,好像是出题者的坑。
浮点数的处理要熟练。
代码的处理体现了公平,没有直接取整,而是分类。
其实我也不明白为什么要这么处理,算了。
该题属于简单题,但涉及一个取整或许有所麻烦,精确解应该是求出平均值,再求偏差绝对值和除 2。这里由于精确到分,求出平均值 mean,按分求出 ceil 和 floor 的值。然后对于每个人,若钱 < mean,求与 floor 偏差绝对值加到总和中,否则与 ceil 求。另外,记录偏差(不取绝对值总和),如果最后总偏差不为 0,要将总偏差绝对值加到总和中。最后输出总和一半即可。
ac代码:

#include <iostream>
#include<cstdio>
using namespace std;

int main()
{
    int n,i;
    double a[1005];//float???
    double s,d;
    while(scanf("%d",&n)&&n!=0)
    {
        s=0;
        for(i=0;i<n;i++)
        {
            scanf("%lf",&a[i]);
            s+=a[i];
            //printf("a[i]=%lf,s=%lf\n",a[i],s);//
        }
        d=s/n;
        int m=d*100;
        double d2=m/100+m%100*0.01;//d2=floor(d)
        double d3;
        //double p1=d-d2,p2=d3-d;
        double s1=0,s2=0;
        //int c1=0,c2=0;
        if(d==d2)
        d3=d2;
        else
        d3=d2+0.01;//d3=ceil(d)
        //printf("s=%lf,d=%lf\n",s,d);//
        //double ans=0;
        for(i=0;i<n;i++)
        {
            if(d>a[i])
            {
                s1+=d2-a[i];//d2,d3交换就错了,大概是出题人的习惯吧。不细究了。
                //c2++;
            }

            else
            {
                s2+=a[i]-d3;
                //c1++;
            }
        }
        if(s1>s2)//取s1,s2中较大的。
        printf("$%.2lf\n",s1);
        else
        printf("$%.2lf\n",s2);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值