关闭

我的仓库

160人阅读 评论(0) 收藏 举报

    

 


// 战场补给概要设计
随机获取枪支子程序

用原来的


随机获取道具子程序()

道具总数量 = 读配置项(配置文件名,gunNumber)
枪支类临时
枪支列表临时
购买标识
是否可以取出
j=1
.计次循环首(道具总数量,i)
 是否可以取出 = 真
 txtTemp=读配置项(配置文件名,"gun"+到文本(i),"subType",) 
 购买标识 = 读配置项(配置文件名,"gun"+到文本(i),"isbuy",) 
 .如果真(txtTemp="1" 或 txtTemp="2")//是喷涂或纹身
  如果真(购买标识="1")
   是否可以取出 = 假
  .如果真结束
 .如果真结束 
 .如果真(是否可以取出)
  txtTemp=读配置项(配置文件名,"gun"+到文本(i),"ename",)
  枪支类临时.置英文名(txtTemp)
  枪支类临时.置大种类(4)
  txtTemp=读配置项(配置文件名,"gun"+到文本(i),"subType",)
  枪支类临时.置小种类(txtTemp)
  txtTemp=读配置项(配置文件名,"gun"+到文本(i),"index",)
  枪支类临时.置枪支索引(到整数(txtTemp))
  枪支列表临时[j]=枪支类临时
  j=j+1
   .如果真结束 
.计次循环尾


//6,点击武器合成
 
1,先从拖拽对象获得武器包的路径,解压到 Program\NewGuns\Temp\下
2,从Program\NewGuns\Temp\Program\weaponInfo.ini中读取英文名和中文名小类型和team
如果设计图和weaponInfo.ini中的小类型不对应,弹出窗口合成失败


在Program\NewGuns\newWeaponCode.ini中找
newWeaponCode.ini
[detail]
gunNumber=2
[newGun1]
ename=aaa
index=
[newGun2]
ename=aaa


如果找得到,把index读出来,根据种类得到配置文件名,根据index把isbuy设为1
如果找不到:
3,根据小类型把登录器代码写入Program\config\store\subtypeXX.ini (先number+1)
否则:如果真找不到,则把新的英文名和中文名写进newWeaponCode.ini去,先number+1

4,通过武器类型把nst代码写入nst_wpn.ini
5,把p d代码写入hud.txt
6,把简介写入Program\config\简介那个简介配置文件
7,复制文件夹,把Program\NewGuns\Temp复制为Program\NewGuns\英文名
8,复制到真实地址,把Program\NewGuns\Temp\Program复制到 取运行目录()+“\Program”
把Program\NewGuns\Temp\cstrike复制到 取运行目录()+“\cstrike“
9,把删除目录(取运行目录()+"Program\NewGuns\Temp") 
重新生成这个文件夹  

 

[detail]
gunNumber=4
m14=1
stg44=2

 [gun1]
 isbuy=1
 ename=m1887
 subType=2
 gunIndex=1
 level=0
 code=[type]1[name]啊啊是[model]m1887[damage]parameter1[speed]parameter2
 paras0=1&1.3&0.9&1.2&240&30
 paras1=
 paras2=
 paras3=
 paras4=
 paras5=
 paras6=
 paras7=
 paras8=
 maxParas=3&2&5&2&3&5&
 paraSerial=1&1&1&2&2&2&
 currentParas=0&0&0&0&0&
 addBullets=1
 
 [gun2]
 isbuy=1
 ename=stg44
 subType=4
 gunIndex=1
 level=0
 code=[type]1[name]啊啊是[model]stg44[damage]parameter1[speed]parameter2
 paras0=1&1.3&0.9&1.2&240&30
 paras1=
 paras2=
 paras3=
 paras4=
 paras5=
 paras6=
 paras7=
 paras8=
 maxParas=3&5&2&3&5
 currentParas=0&0&0&0&0
 addBullets=5
 
 [gun3]
 isbuy=1
 ename=mg3
 subType=4
 gunIndex=1
 level=0
 code=[type]1[name]啊啊是[model]mg3[damage]parameter1[speed]parameter2
 paras0=1&1.3&0.9&1.2&240&30
 paras1=
 paras2=
 paras3=
 paras4=
 paras5=
 paras6=
 paras7=
 paras8=
 maxParas=3&5&2&3&5
 currentParas=0&0&0&0&0
 addBullets=10
 

0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:1986次
    • 积分:42
    • 等级:
    • 排名:千里之外
    • 原创:3篇
    • 转载:0篇
    • 译文:0篇
    • 评论:1条
    文章存档
    最新评论