我的仓库

原创 2012年03月21日 10:01:20

    

 


// 战场补给概要设计
随机获取枪支子程序

用原来的


随机获取道具子程序()

道具总数量 = 读配置项(配置文件名,gunNumber)
枪支类临时
枪支列表临时
购买标识
是否可以取出
j=1
.计次循环首(道具总数量,i)
 是否可以取出 = 真
 txtTemp=读配置项(配置文件名,"gun"+到文本(i),"subType",) 
 购买标识 = 读配置项(配置文件名,"gun"+到文本(i),"isbuy",) 
 .如果真(txtTemp="1" 或 txtTemp="2")//是喷涂或纹身
  如果真(购买标识="1")
   是否可以取出 = 假
  .如果真结束
 .如果真结束 
 .如果真(是否可以取出)
  txtTemp=读配置项(配置文件名,"gun"+到文本(i),"ename",)
  枪支类临时.置英文名(txtTemp)
  枪支类临时.置大种类(4)
  txtTemp=读配置项(配置文件名,"gun"+到文本(i),"subType",)
  枪支类临时.置小种类(txtTemp)
  txtTemp=读配置项(配置文件名,"gun"+到文本(i),"index",)
  枪支类临时.置枪支索引(到整数(txtTemp))
  枪支列表临时[j]=枪支类临时
  j=j+1
   .如果真结束 
.计次循环尾


//6,点击武器合成
 
1,先从拖拽对象获得武器包的路径,解压到 Program\NewGuns\Temp\下
2,从Program\NewGuns\Temp\Program\weaponInfo.ini中读取英文名和中文名小类型和team
如果设计图和weaponInfo.ini中的小类型不对应,弹出窗口合成失败


在Program\NewGuns\newWeaponCode.ini中找
newWeaponCode.ini
[detail]
gunNumber=2
[newGun1]
ename=aaa
index=
[newGun2]
ename=aaa


如果找得到,把index读出来,根据种类得到配置文件名,根据index把isbuy设为1
如果找不到:
3,根据小类型把登录器代码写入Program\config\store\subtypeXX.ini (先number+1)
否则:如果真找不到,则把新的英文名和中文名写进newWeaponCode.ini去,先number+1

4,通过武器类型把nst代码写入nst_wpn.ini
5,把p d代码写入hud.txt
6,把简介写入Program\config\简介那个简介配置文件
7,复制文件夹,把Program\NewGuns\Temp复制为Program\NewGuns\英文名
8,复制到真实地址,把Program\NewGuns\Temp\Program复制到 取运行目录()+“\Program”
把Program\NewGuns\Temp\cstrike复制到 取运行目录()+“\cstrike“
9,把删除目录(取运行目录()+"Program\NewGuns\Temp") 
重新生成这个文件夹  

 

[detail]
gunNumber=4
m14=1
stg44=2

 [gun1]
 isbuy=1
 ename=m1887
 subType=2
 gunIndex=1
 level=0
 code=[type]1[name]啊啊是[model]m1887[damage]parameter1[speed]parameter2
 paras0=1&1.3&0.9&1.2&240&30
 paras1=
 paras2=
 paras3=
 paras4=
 paras5=
 paras6=
 paras7=
 paras8=
 maxParas=3&2&5&2&3&5&
 paraSerial=1&1&1&2&2&2&
 currentParas=0&0&0&0&0&
 addBullets=1
 
 [gun2]
 isbuy=1
 ename=stg44
 subType=4
 gunIndex=1
 level=0
 code=[type]1[name]啊啊是[model]stg44[damage]parameter1[speed]parameter2
 paras0=1&1.3&0.9&1.2&240&30
 paras1=
 paras2=
 paras3=
 paras4=
 paras5=
 paras6=
 paras7=
 paras8=
 maxParas=3&5&2&3&5
 currentParas=0&0&0&0&0
 addBullets=5
 
 [gun3]
 isbuy=1
 ename=mg3
 subType=4
 gunIndex=1
 level=0
 code=[type]1[name]啊啊是[model]mg3[damage]parameter1[speed]parameter2
 paras0=1&1.3&0.9&1.2&240&30
 paras1=
 paras2=
 paras3=
 paras4=
 paras5=
 paras6=
 paras7=
 paras8=
 maxParas=3&5&2&3&5
 currentParas=0&0&0&0&0
 addBullets=10
 

我的爸爸刘狗蛋

我爸姓刘,名抢洞,字狗蛋,是茎洞的掌门人。 2017年6月15日,我的继母“NC妹妹”上了微博热搜,我知道,我爸的公司又要搞活动了。 有些不怀好意的群众喜欢喊她脑残...
  • crazyliyang
  • crazyliyang
  • 2017年06月23日 15:17
  • 882

Github进行fork后如何与原仓库同步(二)

我们之前在《Github进行fork后如何与原仓库同步》这篇博客中详细讲述了如何与原仓库的项目进行同步的问题,看实际的操作流程还是稍显繁琐,其实现在有比前一篇博客中更为优化方便的方法,来让我们实现该功...
  • CHENYUFENG1991
  • CHENYUFENG1991
  • 2017年06月24日 15:30
  • 1187

新创建gitlab仓库上传代码不成功解决

这个问题是因为本地代码和gitlab上面没有进行关联
  • AinUser
  • AinUser
  • 2018年01月14日 14:05
  • 90

github 坑爹的仓库初始化设置

一段时间没有使用 github,奇妙地发现自己连仓库都不会建了,汗一个。。。 话说上次我在 github 上面建了一个仓库,在创建仓库的设置表单中勾上了自动生成 README.md 选项, ok,...
  • LovedPYJ
  • LovedPYJ
  • 2014年08月07日 14:31
  • 874

服务器上建立GIT仓库

又开始胡折腾了, 哈哈, 今天折腾的是服务器建立GIT仓库. 嗯, 是纯仓库. 1. 保证所有操作均在root帐号下, 因为建立的将是server side的GIT仓库 2. 首先建立一个...
  • haigenwong
  • haigenwong
  • 2012年03月30日 12:11
  • 2522

我的保定网上仓库

哈哈,我的一个小小的网站终于今天完成了。有点高兴,在此记录一下。 欢迎大家访问呀,我们这里全部都是高清的图片,不论您想找什么,搜索一下就行了。或者您可以在我们的默认分类里查找,不论是香车美女,还是风景...
  • dx_andy
  • dx_andy
  • 2009年03月13日 23:19
  • 239

linux yum及yum仓库

source: http://www.mamicode.com/info-detail-564351.html 时间:2015-04-12 06:52:57      阅读:1065    ...
  • frankarmstrong
  • frankarmstrong
  • 2016年12月24日 16:53
  • 4281

修改gradle中央仓库,加快访问速度

打开gradle项目的build.gradle文件 找到repositories,注释掉mavenCentral(),使用阿里云的仓库地址 repositories { //maven...
  • mupengfei6688
  • mupengfei6688
  • 2017年11月23日 21:24
  • 209

GitHub仓库的基本操作

在GitHub上存放你的工程文件需要一个仓库,那么今天我们讲讲如何创建仓库?如何使用仓库?如何删除仓库? 【创建仓库】 第一种方法: 在GitHub网页中直接创建,步骤如下: 访问GitHub官网...
  • th_gsb
  • th_gsb
  • 2015年11月23日 10:51
  • 2129

网友关于 yum 仓库的认识

Linux YUM仓库制作 (2012-03-01 15:24:19) 转载▼ 标签: linux yum仓库 xinetd it    ...
  • H002399
  • H002399
  • 2015年04月01日 14:21
  • 856
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:我的仓库
举报原因:
原因补充:

(最多只允许输入30个字)