我的仓库

原创 2012年03月21日 10:01:20

    

 


// 战场补给概要设计
随机获取枪支子程序

用原来的


随机获取道具子程序()

道具总数量 = 读配置项(配置文件名,gunNumber)
枪支类临时
枪支列表临时
购买标识
是否可以取出
j=1
.计次循环首(道具总数量,i)
 是否可以取出 = 真
 txtTemp=读配置项(配置文件名,"gun"+到文本(i),"subType",) 
 购买标识 = 读配置项(配置文件名,"gun"+到文本(i),"isbuy",) 
 .如果真(txtTemp="1" 或 txtTemp="2")//是喷涂或纹身
  如果真(购买标识="1")
   是否可以取出 = 假
  .如果真结束
 .如果真结束 
 .如果真(是否可以取出)
  txtTemp=读配置项(配置文件名,"gun"+到文本(i),"ename",)
  枪支类临时.置英文名(txtTemp)
  枪支类临时.置大种类(4)
  txtTemp=读配置项(配置文件名,"gun"+到文本(i),"subType",)
  枪支类临时.置小种类(txtTemp)
  txtTemp=读配置项(配置文件名,"gun"+到文本(i),"index",)
  枪支类临时.置枪支索引(到整数(txtTemp))
  枪支列表临时[j]=枪支类临时
  j=j+1
   .如果真结束 
.计次循环尾


//6,点击武器合成
 
1,先从拖拽对象获得武器包的路径,解压到 Program\NewGuns\Temp\下
2,从Program\NewGuns\Temp\Program\weaponInfo.ini中读取英文名和中文名小类型和team
如果设计图和weaponInfo.ini中的小类型不对应,弹出窗口合成失败


在Program\NewGuns\newWeaponCode.ini中找
newWeaponCode.ini
[detail]
gunNumber=2
[newGun1]
ename=aaa
index=
[newGun2]
ename=aaa


如果找得到,把index读出来,根据种类得到配置文件名,根据index把isbuy设为1
如果找不到:
3,根据小类型把登录器代码写入Program\config\store\subtypeXX.ini (先number+1)
否则:如果真找不到,则把新的英文名和中文名写进newWeaponCode.ini去,先number+1

4,通过武器类型把nst代码写入nst_wpn.ini
5,把p d代码写入hud.txt
6,把简介写入Program\config\简介那个简介配置文件
7,复制文件夹,把Program\NewGuns\Temp复制为Program\NewGuns\英文名
8,复制到真实地址,把Program\NewGuns\Temp\Program复制到 取运行目录()+“\Program”
把Program\NewGuns\Temp\cstrike复制到 取运行目录()+“\cstrike“
9,把删除目录(取运行目录()+"Program\NewGuns\Temp") 
重新生成这个文件夹  

 

[detail]
gunNumber=4
m14=1
stg44=2

 [gun1]
 isbuy=1
 ename=m1887
 subType=2
 gunIndex=1
 level=0
 code=[type]1[name]啊啊是[model]m1887[damage]parameter1[speed]parameter2
 paras0=1&1.3&0.9&1.2&240&30
 paras1=
 paras2=
 paras3=
 paras4=
 paras5=
 paras6=
 paras7=
 paras8=
 maxParas=3&2&5&2&3&5&
 paraSerial=1&1&1&2&2&2&
 currentParas=0&0&0&0&0&
 addBullets=1
 
 [gun2]
 isbuy=1
 ename=stg44
 subType=4
 gunIndex=1
 level=0
 code=[type]1[name]啊啊是[model]stg44[damage]parameter1[speed]parameter2
 paras0=1&1.3&0.9&1.2&240&30
 paras1=
 paras2=
 paras3=
 paras4=
 paras5=
 paras6=
 paras7=
 paras8=
 maxParas=3&5&2&3&5
 currentParas=0&0&0&0&0
 addBullets=5
 
 [gun3]
 isbuy=1
 ename=mg3
 subType=4
 gunIndex=1
 level=0
 code=[type]1[name]啊啊是[model]mg3[damage]parameter1[speed]parameter2
 paras0=1&1.3&0.9&1.2&240&30
 paras1=
 paras2=
 paras3=
 paras4=
 paras5=
 paras6=
 paras7=
 paras8=
 maxParas=3&5&2&3&5
 currentParas=0&0&0&0&0
 addBullets=10
 

相关文章推荐

数据库系统.数据库与数据仓库导论

  • 2017年10月25日 23:31
  • 47.11MB
  • 下载

仓库管理系统设计

  • 2017年11月16日 17:23
  • 2.12MB
  • 下载

Git小白教程3---远程仓库克隆到本地

远程仓库克隆到本地很简单,用下面这条指令就可以实现git clone git@github.com:[仓库地址]我的Github中有一个名为basic_problem的仓库,现在要克隆到本地进行操作。...

repo 仓库建设方法

  • 2017年11月17日 13:40
  • 1.85MB
  • 下载

数据仓库笔记

  • 2017年11月17日 10:23
  • 5.63MB
  • 下载

eclipse使用maven插件更换maven仓库位置

使用Eclipse集成了Maven插件开发,使用的是Maven的默认配置.经常出现在pom.xml文件中添加了依赖之后jar包下载卡死的过程. 现在提出了两种解决方法.    1  使用本地maven...
  • YSOLA4
  • YSOLA4
  • 2017年02月10日 10:18
  • 903

利用网盘构建svn代码仓库

1、安装网盘 选择一个国内有名的网盘存储,例如金山网盘、360云盘等,注册账户会默认赠送几G的使用空间,然后下载其对应的网盘客户端管理软件(也可以使用浏览器方式),使用账号登录,就可以上传、管理...
  • ccp1994
  • ccp1994
  • 2014年08月22日 10:49
  • 771
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:我的仓库
举报原因:
原因补充:

(最多只允许输入30个字)