HDU6047-Maximum Sequence

Maximum Sequence

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1753 Accepted Submission(s): 815

Problem Description
Steph is extremely obsessed with “sequence problems” that are usually seen on magazines: Given the sequence 11, 23, 30, 35, what is the next number? Steph always finds them too easy for such a genius like himself until one day Klay comes up with a problem and ask him about it.

Given two integer sequences {ai} and {bi} with the same length n, you are to find the next n numbers of {ai}: an+1…a2n. Just like always, there are some restrictions on an+1…a2n: for each number ai, you must choose a number bk from {bi}, and it must satisfy ai≤max{aj-j│bk≤ j< i}, and any bk can’t be chosen more than once. Apparently, there are a great many possibilities, so you are required to find max{∑2nn+1ai} modulo 109+7 .

Now Steph finds it too hard to solve the problem, please help him.

Input
The input contains no more than 20 test cases.
For each test case, the first line consists of one integer n. The next line consists of n integers representing {ai}. And the third line consists of n integers representing {bi}.
1≤n≤250000, n≤a_i≤1500000, 1≤b_i≤n.

Output
For each test case, print the answer on one line: max{∑2nn+1ai} modulo 109+7。

Sample Input
4
8 11 8 5
3 1 4 2

Sample Output
27
Hint

For the first sample:
1. Choose 2 from {bi}, then a_2…a_4 are available for a_5, and you can let a_5=a_2-2=9;
2. Choose 1 from {bi}, then a_1…a_5 are available for a_6, and you can let a_6=a_2-2=9;

Source
2017 Multi-University Training Contest - Team 2

题目大意:给定序列a[1…n],补全a[n+1,…,2n],满足 aimax{ajjbkj<i}
解题思路:贪心

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<queue>
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
const int MOD=1e9+7;
const int MAXN=250000+5;
const int INF=0x3f3f3f3f;
int a[MAXN],b[MAXN],c[MAXN];

int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        mem(c,0);
        for(int i=1;i<=n;++i)
        {
            scanf("%d",&a[i]);a[i]-=i;
        }
        for(int i=1;i<=n;++i)
        {
            scanf("%d",&b[i]);
        }
        sort(b+1,b+n+1);
        for(int i=n;i>=1;--i)
        {
            c[i]=max(c[i+1],a[i]);
        }
        int sum=0,mx=-INF;
        for(int i=1;i<=n;++i)
        {
            int tmp=max(c[b[i]],mx);
            sum=(sum+tmp)%MOD;
            mx=max(mx,tmp-(n+i));
        }
        printf("%d\n",sum);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值