hdu6047--Maximum Sequence

Problem Description

Steph is extremely obsessed with “sequence problems” that are usually seen on magazines: Given the sequence 11, 23, 30, 35, what is the next number? Steph always finds them too easy for such a genius like himself until one day Klay comes up with a problem and ask him about it.

Given two integer sequences {ai} and {bi} with the same length n, you are to find the next n numbers of {ai}: an+1a2n . Just like always, there are some restrictions on an+1a2n : for each number ai , you must choose a number bk from {bi}, and it must satisfy ai ≤max{ aj -j│ bk ≤j<i}, and any bk can’t be chosen more than once. Apparently, there are a great many possibilities, so you are required to find max{ 2nn+1ai } modulo 109 +7 .

Now Steph finds it too hard to solve the problem, please help him.

Input

The input contains no more than 20 test cases.
For each test case, the first line consists of one integer n. The next line consists of n integers representing {ai}. And the third line consists of n integers representing {bi}.
1≤n≤250000, n≤a_i≤1500000, 1≤b_i≤n.

Output

For each test case, print the answer on one line: max{ 2nn+1ai } modulo 109 +7。

Sample Input

  
  
4 8 11 8 5 3 1 4 2

Sample Output

  
  
27

Hint

For the first sample:1. Choose 2 from {bi}, then a_2…a_4 are available for a_5, and you can let a_5=a_2-2=9; 2. Choose 1 from {bi}, then a_1…a_5 are available for a_6, and you can let a_6=a_2-2=9;

题意

已知两个数列a, b,已经给出了a, b的前n项,求数列a的n+1到2*n项,使得这些项的和最大

并且满足aj <= max{ai - i},其中bk <= j < i

bk是数列b中的一项,且每个bk最多仅能取一次

题解

要想使数列a的n+1到2*a项最大,又每项都要减去i

所以应该尽量使bk最小,从最前面开始

(据说是贪心算法??)

那么肯定要先把最大的放进来,这样对后面的也有好处

将b排序,计算ai - i的值

开一个ci 数组记录从i 到n的最大ai-i的值(for循环从n到1遍历)

在第n+1到2*n中,数列肯定是递减的(ai递减,i递增)

每次加的结果要%mod

代码

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#define maxn 250005
#define mod 1000000007
int a[maxn],b[maxn],c[maxn];
using namespace std;
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        memset(c,0,sizeof(c));
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            a[i]-=i;
        }
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&b[i]);
        }
        sort(b+1,b+1+n);
        for(int i=n;i>0;i--)
        {
            c[i]=max(c[i+1],a[i]);
        }
        int  sum=0;
        int  Max=-1;
        for(int i=1;i<=n;i++){
            int kk=max(c[b[i]],Max);
            sum=(sum+kk)%mod;
            Max=max(Max,kk-n-i);
        }
        printf("%d\n",(sum+mod)%mod);


    }
    return 0;
}

链接

http://acm.hdu.edu.cn/showproblem.php?pid=6047


评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值