[Poj 2486] Apple Tree 树形DP

34 篇文章 0 订阅
4 篇文章 0 订阅

Apple Tree
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9069 Accepted: 3016

Description
Wshxzt is a lovely girl. She likes apple very much. One day HX takes her to an apple tree. There are N nodes in the tree. Each node has an amount of apples. Wshxzt starts her happy trip at one node. She can eat up all the apples in the nodes she reaches. HX is a kind guy. He knows that eating too many can make the lovely girl become fat. So he doesn’t allow Wshxzt to go more than K steps in the tree. It costs one step when she goes from one node to another adjacent node. Wshxzt likes apple very much. So she wants to eat as many as she can. Can you tell how many apples she can eat in at most K steps.

Input
There are several test cases in the input
Each test case contains three parts.
The first part is two numbers N K, whose meanings we have talked about just now. We denote the nodes by 1 2 … N. Since it is a tree, each node can reach any other in only one route. (1<=N<=100, 0<=K<=200)
The second part contains N integers (All integers are nonnegative and not bigger than 1000). The ith number is the amount of apples in Node i.
The third part contains N-1 line. There are two numbers A,B in each line, meaning that Node A and Node B are adjacent.
Input will be ended by the end of file.

Note: Wshxzt starts at Node 1.

Output
For each test case, output the maximal numbers of apples Wshxzt can eat at a line.

Sample Input

2 1
0 11
1 2
3 2
0 1 2
1 2
1 3

Sample Output

11
2

Source
POJ Contest,Author:magicpig@ZSU

题目链接http://poj.org/problem?id=2486

题意
一颗树,n个点(1-n),n-1条边,每个点上有一个权值,求从1出发,走V步,最多能遍历到的权值;

思路
树形DP;
dp[i][j][0/1]表示在i的子树下走j步(回到i点用1表示);

dp[x][j][0]=max(dp[x][j][0],dp[x][j-t][1]+dp[y][t-1][0]);//先回x点(-1);
dp[x][j][0]=max(dp[x][j][0],dp[x][j-t][0]+dp[y][t-2][1]);//先回y点-》x点(-2);
dp[x][j][1]=max(dp[x][j][1],dp[x][j-t][1]+dp[y][t-2][1]);//回到x点必回y点(-2)

代码

#include<iostream>
#include<string.h>
#include<stdio.h>
#include<algorithm>
#include<vector>
#include<queue>
using namespace std;
int dp[205][405][2];
int n,k;
vector<int> lin[205];
void dfs(int x,int pre)
{


    for(int i=0;i<lin[x].size();i++)
    {
        int y=lin[x][i];
        if(y==pre) continue;//不搜回边
        dfs(y,x);

        for(int j=k;j>=1;j--)
        for(int t=1;t<=j;t++)
        {
            dp[x][j][0]=max(dp[x][j][0],dp[x][j-t][1]+dp[y][t-1][0]);//先回x点(-1);
            dp[x][j][0]=max(dp[x][j][0],dp[x][j-t][0]+dp[y][t-2][1]);//先回y点-》x点(-2);
            dp[x][j][1]=max(dp[x][j][1],dp[x][j-t][1]+dp[y][t-2][1]);//回到x点必回y点(-2)
        }
    }

}
int main()
{
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        memset(dp,0,sizeof(dp));
        int aa,bb;
        for(int i=1;i<=n;i++)
        {
            lin[i].clear();
            scanf("%d",&aa);
            for(int j=0;j<=k;j++)
            {
                dp[i][j][0]=dp[i][j][1]=aa;//初始化,至少为本节点的值
            }
        }
        for(int i=1;i<n;i++)
        {
            scanf("%d%d",&aa,&bb);
            lin[aa].push_back(bb);
            lin[bb].push_back(aa);
        }
        dfs(1,0);//树形dp,存的双向边,所以默认1
        为根节点;
        printf("%d\n",max(dp[1][k][0],dp[1][k][1]));//答案从1走,回到1与不会的答案;
    }


}
  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值