POJ 2395 Out of Hay (Kruscal最小生成树)

Out of Hay
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 15355 Accepted: 5996

Description

The cows have run out of hay, a horrible event that must be remedied immediately. Bessie intends to visit the other farms to survey their hay situation. There are N (2 <= N <= 2,000) farms (numbered 1..N); Bessie starts at Farm 1. She'll traverse some or all of the M (1 <= M <= 10,000) two-way roads whose length does not exceed 1,000,000,000 that connect the farms. Some farms may be multiply connected with different length roads. All farms are connected one way or another to Farm 1.

Bessie is trying to decide how large a waterskin she will need. She knows that she needs one ounce of water for each unit of length of a road. Since she can get more water at each farm, she's only concerned about the length of the longest road. Of course, she plans her route between farms such that she minimizes the amount of water she must carry.

Help Bessie know the largest amount of water she will ever have to carry: what is the length of longest road she'll have to travel between any two farms, presuming she chooses routes that minimize that number? This means, of course, that she might backtrack over a road in order to minimize the length of the longest road she'll have to traverse.

Input

* Line 1: Two space-separated integers, N and M.

* Lines 2..1+M: Line i+1 contains three space-separated integers, A_i, B_i, and L_i, describing a road from A_i to B_i of length L_i.

Output

* Line 1: A single integer that is the length of the longest road required to be traversed.

Sample Input

3 3
1 2 23
2 3 1000
1 3 43

Sample Output

43

Hint

OUTPUT DETAILS:

In order to reach farm 2, Bessie travels along a road of length 23. To reach farm 3, Bessie travels along a road of length 43. With capacity 43, she can travel along these roads provided that she refills her tank to maximum capacity before she starts down a road.

Source

USACO 2005 March Silver

大体题意:
Bessie 打算从1号农场出发,他需要带水,没走一个单位的路,就会消耗一单位的水,他要走完所有的农场,没经过一个农场,他可以补充任意多的水,求最多带水量?  他可能会走回头路来避免最长路。
思路:
从文中说要避免走最长路就可以看出这是一条最短生成树求最长路的题目!
直接用Kruscal算法!
给边按照权值排序, 优先选择最短边,加上并查集 判断是否有环!  并且要时时判断联通快个数,当个数为1就不用再循环了!
这样不断更新最长边即可!
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<cstdlib>
#include<vector>
#include<set>
#include<map>
#include<stack>
#include<cctype>
#include<string>
#include<iostream>
#include<queue>
#define fout freopen("out.txt","w",stdout);
#define mr make_pair
#define fi first
#define se second
using namespace std;
typedef long long ll;
typedef unsigned long long LLU;
const int maxn = 10000 + 5;
const int mod = 1000000000;
const double eps = 1e-8;
const int inf = 0x3f3f3f3f;
struct Node{
    int x,y,w;
    void read(int xx,int yy,int ww){
        x = xx; y = yy; w = ww;
    }
    bool operator < (const Node & rhs)const {
        return w < rhs.w;
    }
}p[maxn];
int fa[maxn];
int n,m;
int find(int x){
    return fa[x] == x ? fa[x] : fa[x] = find(fa[x]);
}
int Kruscal(){
    int cnt = n;
    int ans = 0;
    for (int i = 0; i <= n; ++i)fa[i] = i;
    for (int i = 0; i < m; ++i){
        int x = find(p[i].x);
        int y = find(p[i].y);
        if (x!=y){
            fa[x] = y;
            ans  = max(ans,p[i].w);
            --cnt;
            if (cnt == 1)break;
        }
    }
    return ans;
}
int main(){

    scanf("%d %d",&n,&m);
    for (int i = 0; i < m; ++i){
        int a, b, w;
        scanf("%d %d %d",&a,&b,&w);
        p[i].read(a,b,w);
    }
    sort(p,p+m);
    printf("%d\n",Kruscal());
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值