POJ 1265 Area (皮克定理)

57 篇文章 0 订阅
Area
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 5737 Accepted: 2564

Description

Being well known for its highly innovative products, Merck would definitely be a good target for industrial espionage. To protect its brand-new research and development facility the company has installed the latest system of surveillance robots patrolling the area. These robots move along the walls of the facility and report suspicious observations to the central security office. The only flaw in the system a competitor抯 agent could find is the fact that the robots radio their movements unencrypted. Not being able to find out more, the agent wants to use that information to calculate the exact size of the area occupied by the new facility. It is public knowledge that all the corners of the building are situated on a rectangular grid and that only straight walls are used. Figure 1 shows the course of a robot around an example area. 

 
Figure 1: Example area. 

You are hired to write a program that calculates the area occupied by the new facility from the movements of a robot along its walls. You can assume that this area is a polygon with corners on a rectangular grid. However, your boss insists that you use a formula he is so proud to have found somewhere. The formula relates the number I of grid points inside the polygon, the number E of grid points on the edges, and the total area A of the polygon. Unfortunately, you have lost the sheet on which he had written down that simple formula for you, so your first task is to find the formula yourself. 

Input

The first line contains the number of scenarios. 
For each scenario, you are given the number m, 3 <= m < 100, of movements of the robot in the first line. The following m lines contain pairs 揹x dy�of integers, separated by a single blank, satisfying .-100 <= dx, dy <= 100 and (dx, dy) != (0, 0). Such a pair means that the robot moves on to a grid point dx units to the right and dy units upwards on the grid (with respect to the current position). You can assume that the curve along which the robot moves is closed and that it does not intersect or even touch itself except for the start and end points. The robot moves anti-clockwise around the building, so the area to be calculated lies to the left of the curve. It is known in advance that the whole polygon would fit into a square on the grid with a side length of 100 units. 

Output

The output for every scenario begins with a line containing 揝cenario #i:� where i is the number of the scenario starting at 1. Then print a single line containing I, E, and A, the area A rounded to one digit after the decimal point. Separate the three numbers by two single blanks. Terminate the output for the scenario with a blank line.

Sample Input

2
4
1 0
0 1
-1 0
0 -1
7
5 0
1 3
-2 2
-1 0
0 -3
-3 1
0 -3

Sample Output

Scenario #1:
0 4 1.0

Scenario #2:
12 16 19.0

Source


大体题意:

一个机器人从(0,0)出发,输入向量表示移动的方向,最后会自交,问最后的多边形 内部的整数点个数和边界整数点个数和多边形面积!


思路:

皮克定理的应用,

1.每输入一个向量,记录当前线段的终点坐标和起点坐标,这样可通过

gcd(abs(x2-x1),abs(y2-y1))来记录边界的整数坐标个数!

2.面积的话可以把多边形拆成几个三角形,用叉积来计算 不断的加即可!

3.最后根据S = a + b / 2 - 1来计算内部点即可!


注意:

1.在计算面积时,相加一定不要取fabs(),因为多边形不规则面积也可能减,所以在最后总面积取一次fabs即可!

2.注意输出格式!

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<cstdlib>
using namespace std;
const int co = 15000;
int gcd(int a,int b){
	return b == 0 ? a : gcd(b,a%b);
}
int main(){
	int T,cnt=0;
	scanf("%d",&T);
	while(T--){
		int n;
		scanf("%d",&n);
		int x1=0,y1=0,x,y;
		double S=0.0;
		int on = 0;
		for (int i = 0; i < n; ++i){
			scanf("%d%d",&x,&y);
			int x2 = x1 + x, y2 = y1 + y;
			on += gcd(abs(x2-x1),abs(y2-y1));
			double s = (x2 * y1 * 1.0 - x1 * y2 * 1.0)/2.0;
			S+=s;
			x1 = x2;y1 = y2;
		}
		S = fabs(S);
		if (cnt )printf("\n");
		printf("Scenario #%d:\n",++cnt);
		printf("%d %d %.1f\n",int(S-on*1.0/2.0+1+0.5),on,S);
		
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值