1006. Sign In and Sign Out (25)

题目链接:http://www.patest.cn/contests/pat-a-practise/1006

题目:

 
 
时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40
Sample Output:
SC3021234 CS301133

分析:

是一个结构体配需,不过涉及到任务结构体和时间结构体,另外还有两个排序函数,因为是要分别求进来的第一个人和出去的最后一个人。

AC代码:

#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
struct Time{
 int hour;
 int min;
 int sec;
};//时间结构体
struct person{
 char name[16];
 Time inTime;
 Time outTime;
}buf[100];//人物结构体
bool t1_Early_t2(Time t1, Time t2){
 if(t1.hour != t2.hour)return t1.hour < t2.hour;
 else if(t1.min != t2.min)return t1.min < t2.min;
 else return t1.sec < t2.sec;
}//时间的比较函数
bool cmp1(person p1, person p2){
 return t1_Early_t2(p1.inTime, p2.inTime);
}//比较函数1,按照进来的时间排序,求第一个来的
bool cmp2(person p1, person p2){
 return t1_Early_t2(p2.outTime, p1.outTime);//t1_Early_t2(p2.outTime, p1.outTime);
}//比较函数2,按照出去的时间排序,注意是倒序,最后一个走的
int main(void){
 int m,i,j;
 while(scanf("%d",&m) != EOF){
  for(i = 0; i < m; i ++){
   scanf("%s %d:%d:%d %d:%d:%d", buf[i].name, &buf[i].inTime.hour, &buf[i].inTime.min, &buf[i].inTime.sec, &buf[i].outTime.hour, &buf[i].outTime.min, &buf[i].outTime.sec);
  }
  sort(buf, buf + m , cmp1);
  for(i = 0; buf[0].name[i] != 0; i ++){
   printf("%c", buf[0].name[i]);
  }
  printf(" ");
  sort(buf, buf + m , cmp2);
  for(i = 0; buf[0].name[i] != 0; i ++){
   printf("%c", buf[0].name[i]);
  }
  printf("\n");
 }
 return 0;
}


P.S:对于时间或日期等格式,读者可以自己多多联系,包括时间类的重载+运算符和比较运算符。

——Apie陈小旭

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值