POJ 2689 Prime Distance【大区间素数筛选】【埃氏筛法】【经典题】

9 篇文章 1 订阅
2 篇文章 0 订阅

Prime Distance
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 18909 Accepted: 5064

Description

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers. 
Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).

Input

Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.

Output

For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.

Sample Input

2 17
14 17

Sample Output

2,3 are closest, 7,11 are most distant.
There are no adjacent primes.

Source


题意:求出L到R区间内相邻素数中离得最近和最远的两对。


因为数字很大,而区间最多是1e6,比较小,所以从区间着手,筛去区间中的所有合数,剩下的就是素数。

筛合数可以先筛出所有的素数,再筛去他们的倍数。

而数字不超过2,147,483,647,所以质因数不会超过sqrt(2,147,483,647),大约是40000多,所以用埃氏筛法筛出50000以内的所有素数,再通过这些素数筛去所有的合数。


注意对a==1时区间左端点为1的特判。

  1.  if (a == 1)  
  2.         not_prime[0] = 1;  


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <cstring>
#define INF 0x3f3f3f3f
#define ms(x,y) memset(x,y,sizeof(x))
using namespace std;

typedef long long ll;

const double pi = acos(-1.0);
const double eps = 1e-8;
const int maxn = 1e6 + 10;

ll a, b;
int num_prime, num_prime2;
bool not_prime[maxn];
int prime[maxn];
ll prime2[maxn];

void get_prime()	//埃氏筛法
{
	ms(not_prime, 0);
	not_prime[1] = 1;
	num_prime = 0;
	for (ll i = 2; i < maxn; i++)
	{
		if (!not_prime[i])
		{
			prime[++num_prime] = i;
			for (ll j = 2 * i; j < maxn; j += i)
				not_prime[j] = 1;
		}
	}
}

void get_prime_ab()		//用得到的素数去筛选a~b
{
	ms(not_prime, 0);
	for (int i = 1; i <= num_prime; i++)
	{
		ll p = a / prime[i];
		if (p <= 1) p = 2;
		for (ll j = prime[i] * p; j <= b; j += prime[i])
		{
			if (j >= a) not_prime[j - a] = 1;
		}
	}
	if (a == 1)
		not_prime[0] = 1;
	num_prime2 = 0;
	for (int i = 0; i <= b - a; i++)
	{
		if (!not_prime[i])
		{
			prime2[++num_prime2] = i + a;
		}
	}
	if (num_prime2 <= 1) printf("There are no adjacent primes.\n");
	else
	{
		ll min = INF, max = -INF, minl, minr, maxl, maxr;
		for (int i = 1; i < num_prime2; i++)
		{
			if (prime2[i + 1] - prime2[i] > max)
			{
				max = prime2[i + 1] - prime2[i];
				maxl = prime2[i];
				maxr = prime2[i + 1];
			}
			if (prime2[i + 1] - prime2[i] < min)
			{
				min = prime2[i + 1] - prime2[i];
				minl = prime2[i];
				minr = prime2[i + 1];
			}
		}
		printf("%lld,%lld are closest, %lld,%lld are most distant.\n", minl, minr, maxl, maxr);
	}
}

int main()
{
	get_prime();
	while (~scanf("%lld%lld", &a, &b))
	{
		get_prime_ab();
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值