【C++】PAT(advanced level)1054. The Dominant Color (20)

1054. The Dominant Color (20)

时间限制
100 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. Astrictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800x600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (<=800) and N (<=600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0, 224). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:
5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24
Sample Output:
24

1.这个人的算法很巧妙.http://blog.csdn.net/zhu_liangwei/article/details/9734671

但是题目换一点就不适用了,太强调技巧性。


2.这个人用到了map我看看map怎么用

http://blog.csdn.net/matrix_reloaded/article/details/8818628

map好用到让我感动死了。

#include<iostream>
#include<string>
#include<map>
using namespace std;

int main()
{
	int a,b;
	cin>>a>>b;
	map<int,int> ans;
	map<int,int>::iterator p;
	int i,j;
	for(i=0;i<b;i++){
		for(j=0;j<a;j++){
			int temp;
			scanf("%d",&temp);
			//cout<<ans[temp];
			ans[temp]++;
		}
	}
	int max=-1,color;
	for(p=ans.begin();p!=ans.end();p++){
		if(p->second>max){
			color=p->first;
			max=p->second;
		}
	}
	cout<<color;
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值