HDU_1789_DoingHomeworkAgain

13 篇文章 0 订阅

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8675    Accepted Submission(s): 5115


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 


Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 


Output
For each test case, you should output the smallest total reduced score, one line per test case.
 


Sample Input
  
  
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 


Sample Output
  
  
0 3 5
 


Author
lcy
 


Source
 


Recommend
lcy

贪心的简单问题。

想法就是从最后的天数开始找,优先做掉分数大的作业。

#include <iostream>
#include <stdio.h>
#include <algorithm>
using namespace std;

const int M=1005;

struct HW
{
    int de,sc;
}hw[M];

int isu[M];

bool cmp(HW a,HW b)         //按时间和分数的降序排列
{
    if(a.de<b.de)
        return 0;
    else if(a.de==b.de&&a.sc<b.sc)
        return 0;
    else
        return 1;
}

void clearhw()
{
    for(int i=0;i<M;i++)
    {
        hw[i].de=0;
        isu[i]=0;
    }
}

int main()
{
    int t;
    int n;
    scanf("%d",&t);
    int maxd;
    int nsc;
    int tot;
    while(t--)
    {
        nsc=0;tot=0;
        clearhw();
        scanf("%d",&n);
        for(int i=0;i<n;i++)
            scanf("%d",&hw[i].de);
        for(int i=0;i<n;i++)
        {
            scanf("%d",&hw[i].sc);
            tot+=hw[i].sc;
        }

        sort(hw,hw+n,cmp);
        maxd=hw[0].de;
        for(int i=maxd;i>=1;i--)
        {
            int ma=0,pma;
            for(int j=0;j<n;j++)
            {
                if(hw[j].de<i)
                    break;
                if(!isu[j]&&hw[j].sc>ma)
                {
                    ma=hw[j].sc;
                    pma=j;
                }
            }
            if(ma)
            {
                nsc+=ma;
                isu[pma]=1;
            }
        }
        printf("%d\n",tot-nsc);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值