Doing Homework again (贪心)

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11332    Accepted Submission(s): 6661


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
  
  
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
  
  
0 3 5
 按分数排序,,
//(思路错了) 
// 按分数高->低 排序,记录当天之前是否用过 
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct Node{
	int d,p;
}w[1010]; 
bool cmp(Node x,Node y)
{
	if(x.p==y.p)
		return x.d<y.d;
	return x.p>y.p;
}
int main()
{
	int t,n,visit[1010];
	scanf("%d",&t);
	while(t--)
	{
		memset(visit,0,sizeof(visit));
		scanf("%d",&n);
		for(int i=0;i<n;i++)		
			scanf("%d",&w[i].d);	
		for(int i=0;i<n;i++)		
			scanf("%d",&w[i].p);	
		sort(w,w+n,cmp);
		int sum=0;
		for(int i=0;i<n;i++)
		{
			int tt=w[i].d;
			 while(tt)
			 {
			 	if(!visit[tt])
				 {
				 	visit[tt]=1;
				 	break;
				 } //这天没用过, 
			 	
				tt--;	//当天被用过,往前推移
			 }
			 if(tt==0)//这天之前都被用过,完不成作业,被罚
			 	sum+=w[i].p; 		 	
		}
		printf("%d\n",sum);	
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值