hdu 5867 (一到一千的模拟题)

Water problem
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 193 Accepted Submission(s): 129

Problem Description
If the numbers 1 to 5 are written out in words: one, two, three, four, five, then there are 3+3+5+4+4=19 letters used in total.If all the numbers from 1 to n (up to one thousand) inclusive were written out in words, how many letters would be used?

Do not count spaces or hyphens. For example, 342 (three hundred and forty-two) contains 23 letters and 115 (one hundred and fifteen) contains 20 letters. The use of “and” when writing out numbers is in compliance with British usage.

Input
There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases.

For each test case: There is one positive integer not greater one thousand.

Output
For each case, print the number of letters would be used.

Sample Input

3
1
2
3

Sample Output

3
6
11

Author
BUPT

Source
2016 Multi-University Training Contest 10

看道题的时候,就不淡定了,这是要考英语啊。
又大神两分钟就A掉了,敢问这题你是有模板吗?

没辙了,百度了一下,一到一千的英语。找规律吧。
交了一下,1A了。卧槽,这也行。

代码:

/*===============================================================
*   Copyright (C) 2016 All rights reserved.
*   
*   Filename: 1011.cpp
*   Author:   gsh
*   Created_time:2016/8/18 星期四 12:08:33
*   Problem_tags: 细节
*   Problem_keyword:
================================================================*/
#include <bits/stdc++.h>
typedef long long ll;
typedef unsigned long long ull;
using namespace std;
int a[] = {3,3,5,4,4,3,5,5,4,3};//1~10
int b[] = {6,6,8,8,7,7,9,8,8,6};//11~20
int c[] = {3,6,6,5,5,5,7,6,6};//1.. /整十
int h = 7;
int work(int n)
{
    if(n == 1000) {return 11;}
    if(n % 100 == 0) {return a[n/100-1] + h;}
    int sum = 0;
    if(n / 100 > 0) {sum += a[n/100 - 1] + h + 3; n %= 100;}
    if(n < 11) {sum += a[n-1];}
    else if(n < 21) {sum += b[n-11];}
    else
    {
        sum += c[n/10-1] + a[n%10-1];
    }
    return sum;
}
int main()
{
#ifdef LOCAL
    freopen("1011.in","r",stdin);
    freopen("1011.out","w",stdout);
#endif
    int t;
    cin >> t;
    while(t--)
    {
        int n;
        cin >> n;
        int ans = 0;
        for(int i = 1; i <= n; i++)
            ans += work(i);
        cout << ans << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值