HDU-5867

16 篇文章 0 订阅
8 篇文章 0 订阅

Water problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1332    Accepted Submission(s): 545


Problem Description
If the numbers 1 to 5 are written out in words: one, two, three, four, five, then there are 3+3+5+4+4=19 letters used in total.If all the numbers from 1 to n (up to one thousand) inclusive were written out in words, how many letters would be used?

Do not count spaces or hyphens. For example, 342 (three hundred and forty-two) contains 23 letters and 115 (one hundred and fifteen) contains 20 letters. The use of "and" when writing out numbers is in compliance with British usage.
 

Input
There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases.

For each test case: There is one positive integer not greater one thousand.
 

Output
For each case, print the number of letters would be used.
 

Sample Input
 
 
3 1 2 3
 

Sample Output
 
 
3 6 11
 

Author
BUPT
 

Source

题意就是让你计算1-n之间每个单词的字母数,例如样例中2,就是one 和two这两个单词中均有3个字母所以就是6

思路:将1-20以及30-100的十位数的每一个单词的字母数存下来,然后就可以将数分解存进数组;然后就么有然后了

代码:

#include<queue>
#include<cmath>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<algorithm>
using namespace std;
int gewei[]= {0,3,3,5,4,4,3,5,5,4,3,6,6,8,8,7,7,9,8,8};
int shiwei[]= {0,0,6,6,5,5,5,7,6,6};
int baiwei,qianwei;
int cnt[1100];
void f()
{
    int i;
    baiwei=7;
    qianwei=8;
    cnt[1000]=11;
    for(i=0; i<1000; i++)
    {
        if(i<20)
        {
            cnt[i]=gewei[i];
        }
        else if(i<100)
        {
            cnt[i]=shiwei[i/10];
            cnt[i]+=gewei[i%10];
        }
        else
        {
            cnt[i]=gewei[i/100]+baiwei;
            if(i%100==0)//个位十位均为0
                continue;
            cnt[i]+=cnt[i%100]+3;
        }
    }
    for(i=0; i<=1000; i++)
        cnt[i]+=cnt[i-1];
}
int main()
{
    int test;
    scanf("%d",&test);
    f();
    while(test--)
    {
        int n;
        scanf("%d",&n);
        printf("%d\n",cnt[n]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值