hdu1034(模拟题)

99 篇文章 2 订阅

http://acm.hdu.edu.cn/showproblem.php?pid=1034

Problem Description
A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to the neighbor on the right. Any student, who ends up with an odd number of pieces of candy, is given another piece by the teacher. The game ends when all students have the same number of pieces of candy. 
Write a program which determines the number of times the teacher blows the whistle and the final number of pieces of candy for each student from the amount of candy each child starts with.
 

Input
The input may describe more than one game. For each game, the input begins with the number N of students, followed by N (even) candy counts for the children counter-clockwise around the circle. The input ends with a student count of 0. Each input number is on a line by itself.
 

Output
For each game, output the number of rounds of the game followed by the amount of candy each child ends up with, both on one line.
 

Sample Input
 
 
6 36 2 2 2 2 2 11 22 20 18 16 14 12 10 8 6 4 2 4 2 4 6 8 0
 

Sample Output
 
 
15 14 17 22 4 8
Hint
The game ends in a finite number of steps because: 1. The maximum candy count can never increase. 2. The minimum candy count can never decrease. 3. No one with more than the minimum amount will ever decrease to the minimum. 4. If the maximum and minimum candy count are not the same, at least one student with the minimum amount must have their count increase.

n个学生围成一圈,每个人手上有a[i]个糖果,一个给下一个自己的一半,当所有人的糖果数一样时游戏结束。

    输出总共进行了多少轮游戏 还有最后学生手中的糖果数。

ps:注意是一个学生得先给出糖果才能接受上一个学生给的,博主一开始没理解,结果一直wrong answeer 后来想到了4 2 2 2 这种情况发现是死循环,才回头去理解题意,几经波折才AC,学好语文很重要啊!

贴上代码

#include<bits/stdc++.h>
using namespace std;
int a[1000];
int n;
bool check(){
	for(int i=1;i<n;i++){
		if(a[i]!=a[i-1]) return true;
	}
	return false;
}
int main(){
	int i,j,cnt=0;
	int t;
	while(scanf("%d",&n),n){
		cnt=0;
		for(i=0;i<n;i++) scanf("%d",&a[i]);
		while(check()){
		int y=a[n-1]/2;
            for(i=n-1;i>0;i--)
            {            
                a[i]=a[i]/2+a[i-1]/2;
                if(a[i]%2)
                    a[i]++;
            }
            a[0]=a[0]/2+y;
            if(a[0]%2)
                a[0]++;
		cnt++;
	}
	cout<<cnt<<" "<<a[0]<<endl;
}
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值