【树状数组--思维】poj 2182 Lost Cows

Lost Cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11826 Accepted: 7609

Description

N (2 <= N <= 8,000) cows have unique brands in the range 1..N. In a spectacular display of poor judgment, they visited the neighborhood 'watering hole' and drank a few too many beers before dinner. When it was time to line up for their evening meal, they did not line up in the required ascending numerical order of their brands. 

Regrettably, FJ does not have a way to sort them. Furthermore, he's not very good at observing problems. Instead of writing down each cow's brand, he determined a rather silly statistic: For each cow in line, he knows the number of cows that precede that cow in line that do, in fact, have smaller brands than that cow. 

Given this data, tell FJ the exact ordering of the cows. 

Input

* Line 1: A single integer, N 

* Lines 2..N: These N-1 lines describe the number of cows that precede a given cow in line and have brands smaller than that cow. Of course, no cows precede the first cow in line, so she is not listed. Line 2 of the input describes the number of preceding cows whose brands are smaller than the cow in slot #2; line 3 describes the number of preceding cows whose brands are smaller than the cow in slot #3; and so on. 

Output

* Lines 1..N: Each of the N lines of output tells the brand of a cow in line. Line #1 of the output tells the brand of the first cow in line; line 2 tells the brand of the second cow; and so on.

Sample Input

5
1
2
1
0

Sample Output

2
4
5
3
1

Source

[Submit]   [Go Back]   [Status]   [Discuss]


题意:有n头牛牛,知道了每只牛牛的左边有多少个比他编号小的牛牛存在数组A中,问每只牛牛的编号;

思路:逆向思维,从后往前遍历A,可以很清楚的知道最后A[n]对应的编号,然后把最后一个删去,求A[n-1]对应的编号,但是刚才已经确定的编号是对之后需确定的是有影响的;

例如:0(手动补上第一个的值)  1  2  1  0  确定最后一个肯定是1;

所以还剩下 2 3 4 5 这些编号,然后确定倒数第二个,对应的编号应该是3;因为1已经被确定了;

方法就是用树状数组记录那个编号已经被确定:k-C[k]=A[i]+1;

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;

const int maxn=8005;
int A[maxn],C[maxn];
int n,ans[maxn];

int lowbit(int k)
{
    return k&(-k);
}

void add(int x,int d)
{
    while(x<=maxn)
    {
        C[x]+=d;
        x+=lowbit(x);
    }
}

int sum(int x)
{
    int ret=0;
    while(x>0)
    {
        ret+=C[x];
        x-=lowbit(x);
    }
    return ret;
}

int bi_search(int x)
{
    int l=1,r=8000;
    while(l<r)
    {
        int mid=(l+r)/2;
//        printf("%d\n",mid);
        if(mid-sum(mid)<x)
            l=mid+1;
        else
            r=mid;

    }
    return l;
}

int main()
{
    scanf("%d",&n);
    memset(C,0,sizeof(C));
    A[1]=1;
    for(int i=2; i<=n; i++)
    {
        scanf("%d",&A[i]);
        A[i]+=1;
    }
    for(int i=n; i>0; i--)
    {
        int k=bi_search(A[i]);
        add(k,1);
        ans[i]=k;
    }

    for(int i=1; i<=n; i++)
        printf("%d\n",ans[i]);
    return 0;
}



1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看REAdMe.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看REAdMe.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看READme.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值