poj 2182 Lost Cows 树状数组

154 篇文章 1 订阅
7 篇文章 0 订阅
Lost Cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9470 Accepted: 6107

Description

N (2 <= N <= 8,000) cows have unique brands in the range 1..N. In a spectacular display of poor judgment, they visited the neighborhood 'watering hole' and drank a few too many beers before dinner. When it was time to line up for their evening meal, they did not line up in the required ascending numerical order of their brands. 

Regrettably, FJ does not have a way to sort them. Furthermore, he's not very good at observing problems. Instead of writing down each cow's brand, he determined a rather silly statistic: For each cow in line, he knows the number of cows that precede that cow in line that do, in fact, have smaller brands than that cow. 

Given this data, tell FJ the exact ordering of the cows. 

Input

* Line 1: A single integer, N 

* Lines 2..N: These N-1 lines describe the number of cows that precede a given cow in line and have brands smaller than that cow. Of course, no cows precede the first cow in line, so she is not listed. Line 2 of the input describes the number of preceding cows whose brands are smaller than the cow in slot #2; line 3 describes the number of preceding cows whose brands are smaller than the cow in slot #3; and so on. 

Output

* Lines 1..N: Each of the N lines of output tells the brand of a cow in line. Line #1 of the output tells the brand of the first cow in line; line 2 tells the brand of the second cow; and so on.

Sample Input

5
1
2
1
0

Sample Output

2
4
5
3
1

这题严格的来说,并不算是我做的。全程百度。看别人的题解才完成的,而且还看了很长时间。。哎,愚笨的自己。我给你们博客地址,你们自己去看吧。http://blog.csdn.net/xingyeyongheng/article/details/20943335
下面我的代码(囧,相似度好高的):
 
 
#include <stdio.h>
#define MAX 10000
 
int t[MAX] ;

int lowbit(int x)
{
	return x&(-x) ;
}

void update(int pos)
{
	while(pos<MAX)
	{
		t[pos]++ ;
		pos += lowbit(pos) ;
	}
}

int query(int pos)
{
	int count = 0 ;
	while(pos>0)
	{
		count += t[pos] ;
		pos -= lowbit(pos) ;
	}
	return count ;
}

int search(int n , int x)
{
	int left = 1 , right = n ;
	while(left<right)
	{
		int mid = (left+right)>>1 ;
		if(mid-1-query(mid) >= x)
		{
			right = mid ;
		}
		else
		{
			left = mid + 1;
		}
	}
	return left ;
}

int main()
{
	int n , input[MAX];
	while(~scanf("%d",&n) )
	{
		input[0] = 0;
		for(int i = 1 ; i < n ; ++i)
		{
			scanf("%d",&input[i]) ;
		}
		
		for(int i = n-1 ; i >= 0 ; --i)
		{
			int x = search(n,input[i]) ;
			input[i] = x ;
			update(x) ;
		}
		for(int i = 0 ; i < n ; ++i)
		{
			printf("%d\n",input[i]) ;
		}
	}
	
	return 0 ;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值