数据结构实验之栈三:后缀式求值(java实现)

8 篇文章 0 订阅

数据结构实验之栈三:后缀式求值

Time Limit: 1000MS  Memory Limit: 65536KB
Problem Description
对于一个基于二元运算符的后缀表示式(基本操作数都是一位正整数),求其代表的算术表达式的值。
Input
输入一个算术表达式的后缀式字符串,以‘#’作为结束标志。
Output
求该后缀式所对应的算术表达式的值,并输出之。
Example Input
59*684/-3*+#
Example Output
57
Hint
基本操作数都是一位正整数!
Author
题解:

后缀表达式:不包含括号,运算符放在两个运算对象的后面,所有的计算按运算符出现的顺序,严格从左向右进行
如 题目中(59*684/-3*+#)正常表达为(5*9+(6-8/4)*3)

import java.util.Scanner;
import java.util.Stack;


public class test {
	public static void main(String[] args) {
		
		Scanner cin = new Scanner(System.in);
		Stack stack =new Stack();
		String str = cin.nextLine();
		int m=0,n=0;
		for (int i = 0; str.charAt(i)!='#'; i ++){
			if(str.charAt(i)>='0'&&str.charAt(i)<='9'){
				stack.push(str.charAt(i)-'0');
			}
			else if(str.charAt(i)=='+'){
				 m=(Integer)stack.peek();
				 stack.pop();
				 n=(Integer)stack.peek();				 
				 stack.pop();
				 stack.push(n+m);
			}
			else if(str.charAt(i)=='-'){
				 m=(Integer)stack.peek();
				 stack.pop();
				 n=(Integer)stack.peek();				 
				 stack.pop();
				 stack.push(n-m);
			}
			else if(str.charAt(i)=='*'){
				 m=(Integer)stack.peek();
				 stack.pop();
				 n=(Integer)stack.peek();				 
				 stack.pop();
				 stack.push(n*m);
			}
			else if(str.charAt(i)=='/'){
				 m=(Integer)stack.peek();
				 stack.pop();
				 n=(Integer)stack.peek();				 
				 stack.pop();
				 stack.push(n/m);
			}
		}
		System.out.print(stack.peek());
	}
}

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值