【杭电oj1576】A/B



A/B

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3346    Accepted Submission(s): 2540


Problem Description
要求(A/B)%9973,但由于A很大,我们只给出n(n=A%9973)(我们给定的A必能被B整除,且gcd(B,9973) = 1)。
 

Input
数据的第一行是一个T,表示有T组数据。
每组数据有两个数n(0 <= n < 9973)和B(1 <= B <= 10^9)。
 

Output
对应每组数据输出(A/B)%9973。
 

Sample Input
      
      
2 1000 53 87 123456789
 

Sample Output
      
      
7922 6060
 



思路:扩展欧几里得求出乘法逆元就可以了。


AC代码:


#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
typedef long long LL;
using namespace std;
void gcdex(LL a,LL b,LL& d,LL& x,LL& y){
	if(b==0){
		d=a,x=1,y=0;
	}
	else{
		gcdex(b,a%b,d,y,x);
		y-=x*(a/b);
	}
} 
LL solved(LL a,LL b){
	LL x,y,d;
	gcdex(a,b,d,x,y);
	return d==1?(x+b)%b:-1;
}
int main(){
	int T;
	scanf("%d",&T);
	while(T--){
		LL n,B;
		scanf("%lld%lld",&n,&B);
		printf("%lld\n",n*solved(B,9973)%9973);
	}
	return 0;
}
题目地址:http://acm.split.hdu.edu.cn/showproblem.php?pid=1576

评论 5
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值