杭电oj第1000题—— A + B Problem

题述如下:

Problem Description
Calculate A + B.

Input
Each line will contain two integers A and B. Process to end of file.

Output
For each case, output A + B in one line.    \\注意,此处强调一行一输出,即输出后跟“\n”

Sample Input
1 1    \\注意,两数字间存在的字符为空格

Sample Output
2

参考程序如下:

#include <stdio.h>

int main()
{
    int a,b;
    while(scanf("%d %d",&a,&b)!=EOF)
    {
        printf("%d\n",a+b);
    }
}

 第一次自己编写的程序如下:

#include <stdio.h>
int main(int argc,char **argv)
{
    int a,b,c,d;
    do
    {
        printf("a=");
        c=scanf("%d",&a);
        getchar();
        printf("b=");
        d=scanf("%d",&b);
        getchar();
        if(c!=EOF&&d!&#
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值