杭电oj-A + B Problem II

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2
1 2
112233445566778899 998877665544332211

Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

solution

大数加法

注意事项

1.要注意边界问题,比如0+0=0,9999+999999999这种
2.要注意符合题目要求:最后一次输出不需要换行,Case第一个字母要大写

代码

import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int n = sc.nextInt();
        for(int i = 1;i <= n; i++){
            String n1 = new StringBuffer(sc.next()).reverse().toString();
            String n2 = new StringBuffer(sc.next()).reverse().toString();
            int length_max = n1.length() > n2.length()? n1.length()+1: n2.length()+1;
            int[] result = new int[length_max];
            int[] int_n1 = new int[length_max];
            int[] int_n2 = new int[length_max];

            for (int f = 0; f < n2.length(); f++) {
                int_n2[f] = Integer.parseInt(String.valueOf(n2.charAt(f)));
            }
            for (int f = 0; f < n1.length(); f++) {
                int_n1[f] = Integer.parseInt(String.valueOf(n1.charAt(f)));
            }
            for( int j = 0; j < length_max - 1; j++){
                int a = result[j] + int_n1[j] + int_n2[j];
                result[j] = a % 10;
                result[j+1] += a / 10;
            }
            System.out.println("Case "+i+":");
            System.out.print(new StringBuffer(n1).reverse().toString() + " + " + new StringBuffer(n2).reverse().toString() + " = ");
            int flag = 0;
            if(n1.length() == 1 && n2.length() == 1 && int_n1[n1.length()-1] == 0 && int_n2[n2.length()-1] == 0){
                System.out.print("0");
            }else {
                for(int j = result.length - 1; j>=0; j--){
                    if(result[j] != 0 || flag != 0){
                        System.out.print(result[j]);
                        flag = 1;
                    }
                }
            }
            System.out.println();
            if(i < n){
                System.out.println();
            }
        }
    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值