Matrix Multiplication
Let us consider undirected graph G = which has N vertices and M edges. Incidence matrix of this graph is N * M matrix A = {aij}, such that aij is 1 if i-th vertex is one of the ends of j-th edge and 0 in the other case. Your task is to find the sum of all elements of the matrix ATA.
This problem contains multiple test cases!
The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.
The output format consists of N output blocks. There is a blank line between output blocks.
Input
The first line of the input file contains two integer numbers - N and M (2 <= N <= 10 000, 1 <= M <= 100 000). 2M integer numbers follow, forming M pairs, each pair describes one edge of the graph. All edges are different and there are no loops (i.e. edge ends are distinct).
Output
Output the only number - the sum requested.
Sample Input
1
4 4
1 2
1 3
2 3
2 4
Sample Output
18
思路:要求的是A矩阵和A的转置矩阵的积,列一下矩阵会发现,实际上就是求Aij(1<=i<=n,1<=j<=m)的平方的和(这好像是求一个矩阵和它的转置矩阵之积的规律?)。
其实根据线性代数里面的公式,就是矩阵的第K行的和和第K列的和的乘积之和。
代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define maxn 100010
int a[maxn];
int n,m;
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
memset(a,0,sizeof(a));
int x,y;
scanf("%d%d",&n,&m);
for(int i=1;i<=m;++i)
{
scanf("%d%d",&x,&y);
++a[x],++a[y];
}
int ans=0;
for(int i=1;i<=n;++i)
ans+=a[i]*a[i];
printf("%d\n",ans);
if(t)
printf("\n");
}
return 0;
}