ZOJ 2319 Beautiful People(最长单调递增子序列)(二维LIS)

Beautiful People

The most prestigious sports club in one city has exactly N members. Each of its members is strong and beautiful. More precisely, i-th member of this club (members being numbered by the time they entered the club) has strength Si and beauty Bi. Since this is a very prestigious club, its members are very rich and therefore extraordinary people, so they often extremely hate each other. Strictly speaking, i-th member of the club Mr X hates j-th member of the club Mr Y if Si <= Sj and Bi >= Bj or if Si >= Sj and Bi <= Bj (if both properties of Mr X are greater then corresponding properties of Mr Y, he doesn��t even notice him, on the other hand, if both of his properties are less, he respects Mr Y very much).

To celebrate a new 2005 year, the administration of the club is planning to organize a party. However they are afraid that if two people who hate each other would simultaneouly attend the party, after a drink or two they would start a fight. So no two people who hate each other should be invited. On the other hand, to keep the club prestige at the apropriate level, administration wants to invite as many people as possible.

Being the only one among administration who is not afraid of touching a computer, you are to write a program which would find out whom to invite to the party.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

Input

The first line of the input file contains integer N - the number of members of the club. (2 <= N <= 100 000). Next N lines contain two numbers each - Si and Bi respectively (1 <= Si, Bi <= 109).

Output

On the first line of the output file print the maximum number of the people that can be invited to the party. On the second line output N integers - numbers of members to be invited in arbitrary order. If several solutions exist, output any one.

Sample Input

1

4
1 1
1 2
2 1
2 2

Sample Output

2
1 4

思路:
因为一个人的Si和Bi都严格小于另外一个人的Si和Bi时,这两个人才不会互相讨厌。所以可以先对Si从小到大排序,如果Si相同则把Bi从大到小排序,这样问题就转化为了求最长上升子序列。当Si相同时之所以要对Bi从大到小排序,是因为如果Bi递增的话,那么选出的方案中会将Si相同的几个人都包含进去,不符合题目要求。然后就用O(nlogn)的算法求最长上升子序列的同时,记录到达每一个数时的最大长度。最后从最大长度向下输出路径即可。

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

#define maxn 100010
struct node
{
    int si,bi,pos;
} q[maxn];
int dp[maxn],mark[maxn];

bool cmp(node a,node b)
{
    if(a.si==b.si)
        return a.bi>b.bi;
    return a.si<b.si;
}

int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=0; i<n; ++i)
        {
            scanf("%d%d",&q[i].si,&q[i].bi);
            q[i].pos=i+1;
        }
        sort(q,q+n,cmp);
        int len=0;
        dp[++len]=q[0].bi,mark[0]=len;
        for(int i=1; i<n; ++i)
        {
            if(dp[len]<q[i].bi)
                dp[++len]=q[i].bi,mark[i]=len;
            else
            {
                int l=1,r=len;//二分查找
                while(l<=r)
                {
                    int mid=(l+r)>>1;
                    if(dp[mid]>=q[i].bi)
                        r=mid-1;
                    else
                        l=mid+1;
                }
                dp[l]=q[i].bi;
                mark[i]=l;
            }
        }
        printf("%d\n",len);
        for(int i=n-1; i>=0; --i)
        {
            if(mark[i]==len)
            {
                printf(len==1?"%d\n":"%d ",q[i].pos);
                --len;
            }
        }
        if(t)
            printf("\n");
    }
    return 0;
}



总结:这个题写的时候是直接套的最长单调递增子序列nlogn的模板,但是对模板一点也不熟悉,不知道为什么dp[]存的并不一定是符合题意的最长单调递增子序列,所以一直wa啊wa。。。

上面用的那种存储路径的方法刚好巧妙地输出了正确的路径,太妙了!

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值