poj3186——Treats for the Cows(区间dp)

Description

FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time.

The treats are interesting for many reasons:
The treats are numbered 1..N and stored sequentially in single file in a long box that is open at both ends. On any day, FJ can retrieve one treat from either end of his stash of treats.
Like fine wines and delicious cheeses, the treats improve with age and command greater prices.
The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).
Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.
Given the values v(i) of each of the treats lined up in order of the index i in their box, what is the greatest value FJ can receive for them if he orders their sale optimally?

The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.
Input

Line 1: A single integer, N

Lines 2..N+1: Line i+1 contains the value of treat v(i)
Output

Line 1: The maximum revenue FJ can achieve by selling the treats
Sample Input

5
1
3
1
5
2
Sample Output

43

题意是给一串长度为n的数字序列,每次只能从队首或队尾出列,出列时对应的数字乘以出列顺序,最后全部加起来,求最大的值。
学习下区间dp。这种题一般都会枚举区间长度,然后向外按照题意扩展。
本体是从最后卖的物品开始,dp到最先卖出的物品,区间长度当然也是从小到大。

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <cmath>
#include <map>
#include <algorithm>
#define INF 0x3f3f3f3f
#define MAXN 2005
#define Mod 10001
using namespace std;
int a[MAXN],dp[MAXN][MAXN]; //dp[i][j]表示i~j这个区间的最优解
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=1; i<=n; ++i)
            scanf("%d",&a[i]);
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;++i)
            dp[i][i]=n*a[i]; //初始条件,只有一个数的时候最优解是最后一天卖
        for(int len=1; len<n; ++len) //枚举区间长度
        {
            for(int i=1; i+len<=n; ++i) //i为队首,j为队尾
            {
                int j=i+len;
                //两个子问题对应从队首出列和从队尾出列,出列时的顺序应是从n-1往1倒数,最后出列的其实是第一个卖出的
                dp[i][j]=max(dp[i+1][j]+(n-len)*a[i],dp[i][j-1]+(n-len)*a[j]); 
            }
        }
        printf("%d\n",dp[1][n]);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值