4.3.4 Sticks

Sticks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 323    Accepted Submission(s): 105


 

Problem Description
George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were originally. Please help him and design a program which computes the smallest possible original length of those sticks. All lengths expressed in units are integers greater than zero.
Input
The input contains blocks of 2 lines. The first line contains the number of sticks parts after cutting, there are at most 64 sticks. The second line contains the lengths of those parts separated by the space. The last line of the file contains zero.
Output
The output file contains the smallest possible length of original sticks, one per line.
Sample Input
9
5 2 1 5 2 1 5 2 1
4
1 2 3 4
0
Sample Output
6
5
 
#include<cstdio>
#include<vector>
#include<cstring>
#include<algorithm>
using namespace std;

const int MAXN = 64;
int s[MAXN], vis[MAXN];
vector<int> stick[MAXN];
int finish;

int  n, MAXS, SUM;
int cmp(const void *a,const void *b)
{
  return *(int*)b-*(int*)a;
}
void dfs(int cur, int psum, int sum){
		int i;
	if(psum == sum){
		dfs(cur+1, 0, sum);
		return;
	}
	if(psum == 0 && cur == SUM / sum){
		finish = 1;
		return;
	}
	if(psum == 0){
	
		if(cur == 0) i = 0;
		else i = stick[cur-1].front()+1;  
		for(;i<n && vis[i];i++);  //key 
			if(s[i] <= sum){
				stick[cur].push_back(i);
				vis[i] = 1;
				dfs(cur, s[i], sum);
				vis[i] = 0;
				stick[cur].pop_back();
			}
		
	}
	else{
		
		for(i = stick[cur].back()+1;!finish && i < n; i++){
			if(vis[i] ||s[i] + psum > sum) continue;
			stick[cur].push_back(i);
			vis[i] = 1;
			dfs(cur, psum+ s[i], sum);
			vis[i] = 0;
			stick[cur].pop_back();
			if(psum+s[i] == sum) break;  //终止这个cur上的查找 
		}
	}
}
int main(){
	int i;
	while(scanf("%d", &n) && n){
		MAXS = SUM = 0;
		for(i = 0; i < n; i++){
			scanf("%d", &s[i]);
			if(MAXS < s[i]){
				MAXS = s[i];
			}
			SUM += s[i];
		}
		qsort(s, n,sizeof(s[0]), cmp);
		finish = 0;
		//for(int i = 0; i < n; i++) printf("%d", s[i]);
	//	printf("%d%d\n", MAXS, SUM);
		for( i = MAXS; i <= SUM; i++){
			if(SUM % i != 0) continue;
			memset(vis, 0, sizeof(vis));		
			for(int j=0;j<n;j++)  stick[j].clear();
			dfs(0, 0, i);
			if(finish == 1) {
			
				break;
			}
		}
			printf("%d\n", i);
	}
	return 1;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值