6.3.5 50 years, 50 colors

50 years, 50 colors

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 80    Accepted Submission(s): 57

 
Problem Description
On Octorber 21st, HDU 50-year-celebration, 50-color balloons floating around the campus, it's so nice, isn't it? To celebrate this meaningful day, the ACM team of HDU hold some fuuny games. Especially, there will be a game named "crashing color balloons".

There will be a n*n matrix board on the ground, and each grid will have a color balloon in it.And the color of the ballon will be in the range of [1, 50].After the referee shouts "go!",you can begin to crash the balloons.Every time you can only choose one kind of balloon to crash, we define that the two balloons with the same color belong to the same kind.What's more, each time you can only choose a single row or column of balloon, and crash the balloons that with the color you had chosen. Of course, a lot of students are waiting to play this game, so we just give every student k times to crash the balloons.

Here comes the problem: which kind of balloon is impossible to be all crashed by a student in k times.


Input
There will be multiple input cases.Each test case begins with two integers n, k. n is the number of rows and columns of the balloons (1 <= n <= 100), and k is the times that ginving to each student(0 < k <= n).Follow a matrix A of n*n, where Aij denote the color of the ballon in the i row, j column.Input ends with n = k = 0.
Output
For each test case, print in ascending order all the colors of which are impossible to be crashed by a student in k times. If there is no choice, print "-1".
Sample Input
1 1
1
2 1
1 1
1 2
2 1
1 2
2 2
5 4
1 2 3 4 5
2 3 4 5 1
3 4 5 1 2
4 5 1 2 3
5 1 2 3 4
3 3
50 50 50
50 50 50
50 50 50
0 0
Sample Output
-1
1
2
1 2 3 4 5
-1
 
问题的意思是选择k条行或者列,去掉选定的颜色,问结果能不能把这种颜色全部去掉。
如果在(i, j)这个点是红色,可以选择第i行或者第j列让这个点删除。假如(i, k)这个点也是红色,则可以选择i行或者k列让这个点删除。如果把x{1,2,3...n}, y{1,2,3...}
看做二分的,则(i, j),(i, k)间各有一条边相连,我们只要选择删除i行就可以做到删掉这两个点,因此问题转化为最小顶点覆盖。
 
#include<cstdio>
#include<cstring>
using namespace std;

const int MAXN = 100 + 5;
const int MAXC = 50 + 5;
int g[MAXN][MAXN], done[MAXN], link[MAXN];
int color[MAXC], a[MAXC];
int n, k, c;

bool find_match(int k){
	for(int i = 1; i <= n; i++){
		if(g[k][i] == c && !done[i]){
			done[i] = 1;
			if(link[i] == -1 || find_match(link[i])){
				link[i] = k;
				return true;
			}
		}
	}
	return false;
}
int hungary(){
	memset(link, -1, sizeof(link));
	int cnt = 0;
	for(int i = 1; i <= n; i++){
		memset(done, 0, sizeof(done));
		if(find_match(i)) cnt++;
	}
	return cnt;
}
int main(){
	while(~scanf("%d%d", &n, &k) && (n || k)){
		for(int i = 1; i <= n; i++){
			for(int j = 1; j <= n; j++){
				scanf("%d", &g[i][j]);
				color[g[i][j]]++;
			}
		}
		int index = 1;
		memset(a, 0, sizeof(a));
		for(int i = 1; i <= MAXC; i++){
			c = i;
			if(color[i] && hungary() > k){
				a[index++] = i;
			}
		}
		if(index == 1) printf("-1\n");
		else {
			for(int i = 1; i < index-1; i++){
				if(a[i]) printf("%d ", a[i]);
			}
			printf("%d\n", a[index-1]);
		}
	
	}
	return 1;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值