hdu 5038 Grade(北京网络赛)

Grade

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 85    Accepted Submission(s): 55


Problem Description
Ted is a employee of Always Cook Mushroom (ACM). His boss Matt gives him a pack of mushrooms and ask him to grade each mushroom according to its weight. Suppose the weight of a mushroom is w, then it’s grade s is 

s = 10000 - (100 - w)^2

What’s more, Ted also has to report the mode of the grade of these mushrooms. The mode is the value that appears most often. Mode may not be unique. If not all the value are the same but the frequencies of them are the same, there is no mode.
 

Input
The first line of the input contains an integer T, denoting the number of testcases. Then T test cases follow.

The first line of each test cases contains one integers N (1<=N<=10^6),denoting the number of the mushroom.

The second line contains N integers, denoting the weight of each mushroom. The weight is greater than 0, and less than 200.
 

Output
For each test case, output 2 lines.

The first line contains "Case #x:", where x is the case number (starting from 1) 

The second line contains the mode of the grade of the given mushrooms. If there exists multiple modes, output them in ascending order. If there exists no mode, output “Bad Mushroom”.
 

Sample Input
  
  
3 6 100 100 100 99 98 101 6 100 100 100 99 99 101 6 100 100 98 99 99 97
 

Sample Output
  
  
Case #1: 10000 Case #2: Bad Mushroom Case #3: 9999 10000
 


签到题,直接模拟就好,值的个数的最大值*值的种类=n时,是所有值出现的个数相同,需特判值得种类为1,在这wa了一发。。。。

代码:

//328ms
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=10000+100;
int hash[maxn];
int main()
{
    int t,n,x,ca=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        int temp;
        memset(hash,0,sizeof(hash));
        int max=0;
        int cou=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&x);
            temp=10000-(100-x)*(100-x);
            if(hash[temp]==0)
            cou++;
            hash[temp]++;
            if(hash[temp]>max)
            max=hash[temp];
        }
        printf("Case #%d:\n",ca++);
        if(max*cou==n&&cou!=1)
        {
            printf("Bad Mushroom\n");
        }
        else
        {
            int sign=0;
            for(int i=0;i<=10000;i++)
            {
                if(hash[i]==max)
                {
                  if(sign==0)
                  {
                  printf("%d",i);
                  sign=1;
                  }
                  else
                  printf(" %d",i);
                }
            }
            printf("\n");
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值