hdu 5038 Grade(分级)

题目链接:[hdu5038] (http://acm.hdu.edu.cn/showproblem.php?pid=5038)
题目描述:
Grade

Time Limit: 3000/1500 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 1330 Accepted Submission(s): 567

Problem Description
Ted is a employee of Always Cook Mushroom (ACM). His boss Matt gives him a pack of mushrooms and ask him to grade each mushroom according to its weight. Suppose the weight of a mushroom is w, then it’s grade s is

s = 10000 - (100 - w)^2

What’s more, Ted also has to report the mode of the grade of these mushrooms. The mode is the value that appears most often. Mode may not be unique. If not all the value are the same but the frequencies of them are the same, there is no mode.

Input
The first line of the input contains an integer T, denoting the number of testcases. Then T test cases follow.

The first line of each test cases contains one integers N (1<=N<=10^6),denoting the number of the mushroom.

The second line contains N integers, denoting the weight of each mushroom. The weight is greater than 0, and less than 200.

Output
For each test case, output 2 lines.

The first line contains “Case #x:”, where x is the case number (starting from 1)

The second line contains the mode of the grade of the given mushrooms. If there exists multiple modes, output them in ascending order. If there exists no mode, output “Bad Mushroom”.

Sample Input
3
6
100 100 100 99 98 101
6
100 100 100 99 99 101
6
100 100 98 99 99 97

Sample Output
Case #1:
10000
Case #2:
Bad Mushroom
Case #3:
9999 10000

Source
2014 ACM/ICPC Asia Regional Beijing Online
言简意赅:
此题意味用上述公式来给所有的Mushroom分级,并找出其中所有的众数,如果众数唯一,直接输出即可,如果不唯一,则要按升序输出所有的,特别的,有种很特殊的情况就是所有可能成为众数的出现的频率是相等的,此时要输出“Badmushoom”,但是此题没必要按照所有的输入来存储数据,可以直接根据其地位,将其重量处理一下再进行存储和运算,会更加简洁,代码实现如下:

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <cstdlib>
using namespace std;

int a[105];
int b[105];
int main()
{
    int t,n,k;
    int intg;
    scanf("%d",&t);
    for(int loop=1;loop<=t;loop++)
    {
        scanf("%d",&n);
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        for(int i=0;i<n;i++)
        {
            scanf("%d",&intg);
            k=(int)abs(100-intg);
            a[k]++;//根据其地位,按照其出现的次数进行存储
        }
        int max=-99999999;
        int maxi=0;
        for(int i=0;i<=100;i++)//寻找出现次数最多的
        {
            if(a[i]>max)
            {
                max=a[i];
                maxi=i;
            }
        }
        //cout<<"max="<<max<<endl;
        int j=0;
        int count=0;
        for(int i=0;i<=100;i++)
        {
            if(a[i]==max)
            {
                b[j++]=i;
                count++;
            }
        }
//        for(int i=0;i<j;i++)
//        {
//            cout<<"b="<<b[i]<<" ";
//        }
        printf("Case #%d:\n",loop);
        if(count==1)
        {
            printf("%d\n",10000-maxi*maxi);
        }
        else
        {
            if(count*max==n)
            {
                printf("Bad Mushroom\n");
            }
            else
            {
                sort(b,b+j);
                for(int i=j-1;i>=0;i--)
                {
                    if(i==0)
                    printf("%d",10000-b[i]*b[i]);
                    else
                    printf("%d ",10000-b[i]*b[i]);
                }printf("\n");
            }
        }
    }
    return 0;
}

备注:小知识点:关于abs()函数和fabs()函数。
abs()函数用于给整数取绝对值(C++中要加头文件或者是);而fabs()函数则是用于给小数取绝对值(C++中要加头文件或者是),返回值为实型。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值