HDU 5038

这道题题意很坑,本意是如果你的mode不唯一且没有别的grade了,则为“Bad Mushroom”。

故,一共会有三种情况,

1.只有一种mode

2.多组mode且除了mode的grade外还有别的不是mode的grade

3.一组或多组mode但是除了mode没有别的grade,故输出bad mushroom、

题意理解清楚了就很简单了,但是我有个问题,在网上找博客也没法解决,就是:我的程序在外面大循环内只存在两个独立的循环,交C++会蜜汁超时,交G++则没有问题。

十分希望看到这篇博客的人能够帮助我解决这个问题!

Ted is a employee of Always Cook Mushroom (ACM). His boss Matt gives him a pack of mushrooms and ask him to grade each mushroom according to its weight. Suppose the weight of a mushroom is w, then it’s grade s is 

s = 10000 - (100 - w)^2

What’s more, Ted also has to report the mode of the grade of these mushrooms. The mode is the value that appears most often. Mode may not be unique. If not all the value are the same but the frequencies of them are the same, there is no mode.
Input
The first line of the input contains an integer T, denoting the number of testcases. Then T test cases follow. 

The first line of each test cases contains one integers N (1<=N<=10^6),denoting the number of the mushroom. 

The second line contains N integers, denoting the weight of each mushroom. The weight is greater than 0, and less than 200.
Output
For each test case, output 2 lines. 

The first line contains "Case #x:", where x is the case number (starting from 1) 

The second line contains the mode of the grade of the given mushrooms. If there exists multiple modes, output them in ascending order. If there exists no mode, output “Bad Mushroom”.
Sample Input
3
6
100 100 100 99 98 101
6
100 100 100 99 99 101
6
100 100 98 99 99 97
Sample Output
Case #1:
10000
Case #2:
Bad Mushroom
Case #3:
9999 10000
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <vector>
#include <cmath>
#include <map>
using namespace std;

map<int, int> list1;
int list3[100000];

int cal(int num)
{
    return (10000 - (100 - num)* (100 - num));
}

int main()
{
    int t, n, num, rnum, k, maxn;
    scanf("%d", &t);
    k = t;
    while(t--)
    {
        list1.clear();
        scanf("%d", &n);
        maxn = 0;
        for(int i = 0; i < n; i++)
        {
            scanf("%d", &num);
            rnum = cal(num);
            if(list1.count(rnum))
            {
                list1[rnum]++;
            }
            else
            {
                list1[rnum] = 1;
            }
            if(list1[rnum] > maxn) maxn = list1[rnum];
        }
        int time1 = 0;
        map<int, int>::iterator f;
        for(f = list1.begin(); f != list1.end(); ++f)
        {
            if(f -> second == maxn)
            {
                list3[time1++] = f -> first;
            }
        }
       // cout << maxn << endl;
        printf("Case #%d:\n", k - t);
        if(time1 * maxn == n&& time1 > 1)
        {
            printf("Bad Mushroom\n");
        }
        else
        {
            sort(list3, list3 + time1);
            for(int i = 0; i < time1; ++i)
            {
                if(i != 0)
                {
                    printf(" ");
                }
                printf("%d", list3[i]);
            }
            printf("\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值