南邮 OJ 1519 H_TRC1

H_TRC1

时间限制(普通/Java) :  2000 MS/ 6000 MS          运行内存限制 : 65536 KByte
总提交 : 41            测试通过 : 12 

比赛描述

The ternary expansion of a number is that numberwritten in base 3. A number can have more than oneternary expansion. A ternary expansion is indicatedwith a subscript 3. For example, 1 = 1
= 0.222... 3,and 0.875 = 0.212121...
3.The Cantor set is defined as the real numbersbetween 0 and 1 inclusive that have a ternaryexpansion that does not contain a 1. If a number hasmore than one ternary expansion, it is enough for asingle one to not contain a 1.For example, 0 = 0.000...
and 1 = 0.222... 3, sothey are in the Cantor set. But 0.875 = 0.212121...
3and this is its only ternary expansion, so it is notin the Cantor set.Your task is to determine whether a given number is in the Cantor set.



输入

The input consists of several test cases.Each test case consists of a single line containing a number written in decimalnotation, with 0 <= <= 1, and having at most 6 digits after the decimal point.The last line of input is END. This is not a test case.

输出

For each test case, output MEMBER if is in the Cantor set, and NON-MEMBER if isnot in the Cantor set.

样例输入

01
0.875
END

样例输出

MEMBER
MEMBER
NON-MEMBER

提示

undefined

题目来源

Waterloo local contest





/* Wrong Answer at Test 2
#include<iostream>
#include<set>
using namespace std;

int main(){
	double d;
	bool inCantor;
	int i;
	set<double> ds;
	while(scanf("%lf",&d)==1){
		ds.clear();
		inCantor = 1;
		if(d<0 || d>1){
			inCantor = 0;
		}else if(d==0 || d==1){
			inCantor = 1;
		}else{
			while(1){
				d *= 3;
				i = (int)d;
				if(i==1){
					inCantor = 0;
					break;
				}
				d -= i;
				if(ds.count(d)){
					inCantor = 1;
					break;
				}else{
					ds.insert(d);
				}
			}
		}
		if(inCantor){
			printf("MEMBER\n");
		}else{
			printf("NON-MEMBER\n");
		}
	}
}
*/

/* Wrong Answer at Test 2
#include<iostream>
#include<set>
using namespace std;

int main(){
	double d;
	set<double> ds;
	while(scanf("%lf",&d)==1){
		if(d==0 || d==1){
			printf("MEMBER\n");
		}else{						//0.020202……
			printf("NON-MEMBER\n");
		}
	}
}
*/



/* AC 9MS
#include<iostream>
#include<set>
using namespace std;

int main(){
	double d;
	bool inCantor;
	int n,i;
	set<int> is;
	while(scanf("%lf",&d)==1){//有限字长效应,输入0.7会变成0.69999999999999996
		is.clear();
		inCantor = 1;
		n = (int)(d*1000000+0.5);//扩大1000000倍,四舍五入
		if(n<0 || n>1000000){
			inCantor = 0;
		}else if(n==0 || n==1000000){
			inCantor = 1;
		}else{
			while(1){
				n *= 3;
				i = n/1000000;
				n -= i*1000000;
				if(i==1){
					inCantor = 0;
					break;
				}
				if(is.count(n)){
					inCantor = 1;
					break;
				}else{
					is.insert(n);
				}
			}
		}
		if(inCantor){
			printf("MEMBER\n");
		}else{
			printf("NON-MEMBER\n");
		}
	}
}
*/

// AC 6MS
#include<iostream>
#include<set>
using namespace std;

bool b[1000000];

int main(){
	double d;
	bool inCantor;
	int n,i;
	while(scanf("%lf",&d)==1){//有限字长效应,输入0.7会变成0.69999999999999996
		memset(b,0,sizeof(b));
		inCantor = 1;
		n = (int)(d*1000000+0.5);//扩大1000000倍,四舍五入
		if(n<0 || n>1000000){
			inCantor = 0;
		}else if(n==0 || n==1000000){
			inCantor = 1;
		}else{
			while(1){
				n *= 3;
				i = n/1000000;
				n -= i*1000000;
				if(i==1){
					inCantor = 0;
					break;
				}
				if(b[n]){
					inCantor = 1;
					break;
				}else{
					b[n] = 1;
				}
			}
		}
		if(inCantor){
			printf("MEMBER\n");
		}else{
			printf("NON-MEMBER\n");
		}
	}
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 适合毕业设计、课程设计作业。这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。 所有源码均经过严格测试,可以直接运行,可以放心下载使用。有任何使用问题欢迎随时与博主沟通,第一时间进行解答!

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值