hdu1028 poj1644放苹果poj3014 Cake Pieces and Plates----整数划分模板


Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10679    Accepted Submission(s): 7569


Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
  
  
4 10 20
 

Sample Output
  
  
5 42 627
 

Author
Ignatius.L


经典的算法之一-------整数划分问题

可以用递归法,母函数法,

递归法

import java.util.Scanner;

public class hdu1028整数划分 {
	 static long[][]a=new long[122][122];
	
	private static long fun(int n,int m) {
		 if(a[n][m]!=0)return a[n][m];
		 if(n<1||m<1)return 0;
		 if(n==1||m==1)return 1;
		 if(n<m) return a[n][m]=fun(n,n);
		 if(n==m) return a[n][m]=1+fun(n,n-1);
		 return a[n][m]=fun(n,m-1)+fun(n-m,m);
		
	}

	public static void main(String[] args) {
		
		Scanner sc = new Scanner(System.in);
		while(sc.hasNext()){
			int n = sc.nextInt();
			System.out.println(fun(n,n));
		}
	}
}


POJ1644放苹果


放苹果
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 24361 Accepted: 15493

Description

把M个同样的苹果放在N个同样的盘子里,允许有的盘子空着不放,问共有多少种不同的分法?(用K表示)5,1,1和1,5,1 是同一种分法。

Input

第一行是测试数据的数目t(0 <= t <= 20)。以下每行均包含二个整数M和N,以空格分开。1<=M,N<=10。

Output

对输入的每组数据M和N,用一行输出相应的K。

Sample Input

1
7 3

Sample Output

8

Source


import java.util.Scanner;

public class poj放苹果_整数划分变化 {
//1983210400	1664	Accepted	3000K	125MS	Java	581B	2013-11-27 14:45:43
	/**
	 * @param args
	 */
	static int a,b;
	static int[][]s=new int[25][25];
	public static int f(int n,int m){
		if(s[n][m]!=0)return s[n][m];
		if(n<1||m<1) return 0;
		if(n==1||m==1) return 1;
		if(n<m) return s[n][m]=f(n,n);
		if(n==m)return s[n][m]=1+f(n,n-1);
		return s[n][m]=f(n,m-1)+f(n-m,m);
	}
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		int N = sc.nextInt();
		while(N-->0){
			 a=sc.nextInt();
			 b=sc.nextInt();
			System.out.println(f(a,b));
		}
	}
}

DP方法:大牛提供


import java.util.Scanner;
 public class poj1664放苹果_整数划分变化{
	//网上看到的,动态规划方法
	public static void main(String[] args) {
		  Scanner sc = new Scanner(System.in);
		  int []dp;
		    
		   int N=sc.nextInt();
		   while(N-->0){
			      int m=sc.nextInt();//苹果
				  int n=sc.nextInt();//盘子
				  dp=new int [50];
				  dp[0]=1;
				  for(int i=1;i<=n;i++)//盘子
					  for(int j=i;j<=m;j++){//苹果
						  dp[j]+=dp[j-i];
						
					  }
				  System.out.println(dp[m]);		
		   }
	}
}

POJ3014

Cake Pieces and Plates
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 6444 Accepted: 2013
Case Time Limit: 1000MS

Description

kcm1700, ntopia, suby, classic, tkwons, and their friends are having a birthday party for kcm1700. Of course, there is a very large birthday cake. They divide the birthday cake into undistinguishable pieces and put them on identical plates. kcm1700 is curious, so he wants to know how many ways there are to put m cake pieces on n plates.

Input

In the only input line, there are two integers nm (1 ≤ nm ≤ 4 500), which are the number of the plates and the number of the cake pieces respectively.

Output

If the number of ways is K, just output K mod 1000000007 because K can be very large.

Sample Input

3 7

Sample Output

8

Hint

There are 8 ways to fill 3 plates with 7 cakes, namely (0,0,7), (0,1,6), (0,2,5), (0,3,4), (1,1,5), (1,2,4), (1,3,3), (2,2,3).

Source

POJ Monthly--2006.09.29, Kim, Chan Min (kcm1700@POJ)


import java.util.Scanner;
 public class poj1664放苹果_整数划分变化{
	//网上看到的,动态规划方法
	public static void main(String[] args) {
		  Scanner sc = new Scanner(System.in);
		  int []dp;
		    
		   int N=sc.nextInt();
		   while(N-->0){
			      int m=sc.nextInt();//苹果
				  int n=sc.nextInt();//盘子
				  dp=new int [50];
				  dp[0]=1;
				  for(int i=1;i<=n;i++)//盘子
					  for(int j=i;j<=m;j++){//苹果
						  dp[j]+=dp[j-i];
						
					  }
				  System.out.println(dp[m]);		
		   }
	}
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值