poj 1383 Labyrinth 【迷宫图 BFS实现 树的直径裸题】

Labyrinth
Time Limit: 2000MS Memory Limit: 32768K
Total Submissions: 3990 Accepted: 1501

Description

The northern part of the Pyramid contains a very large and complicated labyrinth. The labyrinth is divided into square blocks, each of them either filled by rock, or free. There is also a little hook on the floor in the center of every free block. The ACM have found that two of the hooks must be connected by a rope that runs through the hooks in every block on the path between the connected ones. When the rope is fastened, a secret door opens. The problem is that we do not know which hooks to connect. That means also that the neccessary length of the rope is unknown. Your task is to determine the maximum length of the rope we could need for a given labyrinth.

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers C and R (3 <= C,R <= 1000) indicating the number of columns and rows. Then exactly R lines follow, each containing C characters. These characters specify the labyrinth. Each of them is either a hash mark (#) or a period (.). Hash marks represent rocks, periods are free blocks. It is possible to walk between neighbouring blocks only, where neighbouring blocks are blocks sharing a common side. We cannot walk diagonally and we cannot step out of the labyrinth. 
The labyrinth is designed in such a way that there is exactly one path between any two free blocks. Consequently, if we find the proper hooks to connect, it is easy to find the right path connecting them.

Output

Your program must print exactly one line of output for each test case. The line must contain the sentence "Maximum rope length is X." where Xis the length of the longest path between any two free blocks, measured in blocks.

Sample Input

2
3 3
###
#.#
###
7 6
#######
#.#.###
#.#.###
#.#.#.#
#.....#
#######

Sample Output

Maximum rope length is 0.
Maximum rope length is 8.

Hint

Huge input, scanf is recommended. 

If you use recursion, maybe stack overflow. and now C++/c 's stack size is larger than G++/gcc


题意:给你一个N*M的迷宫,迷宫里面有' # '和 ' . ' 两种字符,问你距离最远的两个' . '之间的距离。


读懂题意就很简单了, 就是在迷宫图里面用二维来模拟一维求树的直径。两次BFS就行了。


思路:首先找到任意一个' . '的坐标(x1, y1),然后以该坐标为起点BFS整个迷宫找最长路,找到该坐标对应最长路的终点(x2, y2)。再以(x2, y2)为起点BFS整个迷宫找最长路即可。


AC代码:


#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>
#define MAXN 1000+10
using namespace std;
struct Node
{
    int x, y, step;
};
Node now, next;
int N, M;
char Map[MAXN][MAXN];
bool vis[MAXN][MAXN];
int sx, sy;
int ans;//最长路 最后的结果
void getMap()
{
    bool flag = false;
    for(int i = 0; i < N; i++)
    {
        scanf("%s", Map[i]);
        if(flag) continue;//找到一个 不用再找第二个
        for(int j = 0; j < M; j++)
        {
            if(Map[i][j] == '.')
            {
                sx = i;
                sy = j;
                flag = true;
            }
        }
    }
}
bool judge(int x, int y)//判断下一位的移动是否合法
{
    return x >= 0 && x < N && y >= 0 && y < M && Map[x][y] != '#' && !vis[x][y];
}
void BFS(int x, int y)
{
    queue<Node> Q;
    int move[4][2] = {0,1, 0,-1, 1,0, -1,0};
    memset(vis, false, sizeof(vis));
    Node now = {x, y, 0};
    Q.push(now);
    ans = 0;
    while(!Q.empty())
    {
        now = Q.front();
        Q.pop();
        for(int k = 0; k < 4; k++)
        {
            next.x = now.x + move[k][0];
            next.y = now.y + move[k][1];
            next.step = now.step + 1;
            if(judge(next.x, next.y))
            {
                vis[next.x][next.y] = true;
                if(next.step > ans)
                {
                    ans = next.step;
                    sx = next.x;
                    sy = next.y;
                }
                Q.push(next);
            }
        }
    }
}
void solve()
{
    BFS(sx, sy);//找S-T端点
    BFS(sx, sy);//找最长路
    printf("Maximum rope length is %d.\n", ans);
}
int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d%d", &M, &N);
        getMap();
        solve();
    }
    return 0;
}


  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值