1054. 求平均值

本题的基本要求非常简单:给定N个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是[-1000,1000]区间内的实数,并且最多精确到小数点后2位。当你计算平均值的时候,不能把那些非法的数据算在内。

输入格式:

输入第一行给出正整数N(<=100)。随后一行给出N个正整数,数字间以一个空格分隔。

输出格式:

对每个非法输入,在一行中输出“ERROR: X is not a legal number”,其中X是输入。最后在一行中输出结果:“The average of K numbers is Y”,其中K是合法输入的个数,Y是它们的平均值,精确到小数点后2位。如果平均值无法计算,则用“Undefined”替换Y。如果K为1,则输出“The average of 1 number is Y”。

输入样例1:
7
5 -3.2 aaa 9999 2.3.4 7.123 2.35
输出样例1:
ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38
输入样例2:
2
aaa -9999
输出样例2:
ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined
 
我写了个C++版本的AC程序。
#include <iostream>
#include <string>
#include <cstdlib>
#include <cmath>
#include <cstring>
#include <cctype>
using namespace std;
bool islegal(char a[], double *b) {
	double tmp = 0;
	int len = strlen(a);
	int i, j, sign = 0, dot = 0;
	for (i = 0, j = 0; i < len; i++) {
		if (i == 0 && a[i] == '-') {
			sign = 1;
		}
		else if (isdigit(a[i]) || a[i] == '.') {
			if (dot) {
				if (a[i] == '.') {
					return false;
				}
				else if (j < 3) {
					tmp = tmp + (a[i] - '0') / pow(10, j++);
				}
				else {
					return false;
				}
			}
			else {
				if (a[i] == '.') {
					j++;
					dot++;
				}
				else {
					tmp = tmp * 10 + a[i] - '0';
				}
			}
		}
		else {
			return false;
		}
	}
	if (tmp > 1000) {
		return false;
	}
	else if (sign) {
		*b = tmp * -1;
	}
	else {
		*b = tmp;
	}
	return true;
}

int main() {
	int num = 0;
	cin >> num;

	double average = 0;
	char stmp[100];
	double dtmp;
	int count = 0;
	for (int i = 0; i < num; i++) {
		cin >> stmp;
		if (islegal(stmp, &dtmp)) {
			average += dtmp;
			count++;
		}
		else {
			cout << "ERROR: " << stmp << " is not a legal number\n";
		}
	}
	//The average of 0 numbers is Undefined
	if (count == 0) {
		cout << "The average of 0 numbers is Undefined";
	}
	else if (count == 1) {
		cout << "The average of " << count << " number is ";
		printf("%.2lf", average / double(count));
	}
	else {
		cout << "The average of " << count << " numbers is ";
		printf("%.2lf", average / double(count));
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值