解决'GLIBC_2.14' not found问题时遇到的坑

原创 2017年03月16日 16:44:08

最近用到c++11需要升级glibc库。

网上有很多解决'GLIBC_2.14' not found问题的帖子。

无非就是如下的一些操作命令:

1. glibc下载
从http://www.gnu.org/software/libc/ 下载源代码。我下载的版本是2.14,链接地址是http://ftp.gnu.org/gnu/glibc/glibc-2.14.tar.gz。
2. 安装
具体步骤如下:
[root@localhost ~]# tar zxvf glibc-2.14.tar.gz -C /home/software/
[root@localhost ~]# cd /home/software/glibc-2.14
[root@localhost glibc-2.14]# mkdir /opt/build
[root@localhost glibc-2.14]# cd build
[root@localhost build]# ../configure --prefix=/opt/glibc-2.14
[root@localhost build]# make -j4
[root@localhost build]# make install
如果没有碰到坑,那么恭喜你已经完成了安装,后续也就是库环境设置了。

下面先说一下遇到的坑:

1、在make过程中出现如下错误:

/usr/bin/install: `include/limits.h' and `/opt/glibc-2.14/include/limits.h' are the same file


在经过google后,不太理解相关帖子的含义,后来自行修炼后,明白了。

原因就是楼主解压的glic-2.14.tar.gz源码和编译时定义的目录../configure --prefix=/home/software/glibc-2.14放到了一起。

所以解决方法就是:

tar zxvf glibc-2.14.tar.gz -C /home/software/
../configure --prefix=/opt/glibc-2.14

只要将编译定义目录和源码目录区分开就ok了。



2、在make install过程中出现如下错误:

Can't open configuration file /opt/glibc-2.14/etc/ld.so.conf: No such file or directory


就是缺少了必要的编译文件ld.so.conf。通过find命令找到对应的文件位置。

[root@localhost build]# find / -name "ld.so.conf"
/etc/ld.so.conf


然后我们执行命令把此文件拷贝到对应的文件目录下去,然后继续编译。

[root@localhost build]# cp /etc/ld.so.conf /opt/glibc-2.14/etc/
[root@localhost build]# make install

Congratulations! 编译成功!


最后就是设置环境变量,因为glibc库使用广泛,为了避免污染当前系统环境,在使用时候定义一下环境变量。

执行命令

[root@localhost ~]# export LD_LIBRARY_PATH=/opt/glibc-2.14/lib:$LD_LIBRARY_PATH

将库的位置临时定位在/opt/glibc-2.14/lib位置。

此时再执行相关程序即可顺利运行。




版权声明:本文为博主原创文章,未经博主允许不得转载。

解决libc.so.6: version `GLIBC_2.14' not found问题

0.以下在系统CentOS 6.3 x86_64上操作 1.试图运行程序,提示"libc.so.6: version `GLIBC_2.14' not found",原因是系统的glibc版本太低,软...
  • iomato
  • iomato
  • 2013年01月04日 00:05
  • 121662

CentOS安装glibc-2.14

到http://ftp.gnu.org/gnu/glibc/下载glibc-2.14.tar.xz tar glibc-2.14.tar.gz cd glibc-2.14 mkdir build cd...
  • niying
  • niying
  • 2015年01月07日 14:06
  • 46142

解决libc.so.6: version `GLIBC_2.14' not found问题

1.试图运行程序,提示"libc.so.6: version `GLIBC_2.14' not found",原因是系统的glibc版本太低,软件编译时使用了较高版本的glibc引起的: ...
  • azhangyi188
  • azhangyi188
  • 2016年08月07日 03:15
  • 1825

glibc-2.14.tar依赖包

  • 2017年09月25日 12:56
  • 19.93MB
  • 下载

version `GLIBC_2.14' not found 解决方法.

参考: http://blog.csdn.net/force_eagle/article/details/8684669 http://blog.csdn.net/iomato/article...
  • dadoneo
  • dadoneo
  • 2013年04月26日 19:24
  • 25537

version `GLIBC_2.14' not found 解决方法.

version `GLIBC_2.14' not found 解决方法. 一般出现类似次问题是当前运行系统Glibc版本低于编译环境Glibc版本造成Glibc版本兼容性造成的.   通常可以使用...
  • force_eagle
  • force_eagle
  • 2013年03月17日 20:48
  • 43444

升级glibc到2.14

转载:https://my.oschina.net/zhangxu0512/blog/262275今天运行一个例程,出现了/lib64/libc.so.6: version `GLIBC_2.14' ...
  • qianlong4526888
  • qianlong4526888
  • 2016年11月23日 16:50
  • 6388

解决 version `GLIBC_2.14' not found 解决方法.

  • 2014年08月11日 10:52
  • 1KB
  • 下载

升级GLIBC_2.14

参考:     http://my.oschina.net/zhangxu0512/blog/262275     http://blog.csdn.net/GraceLand525/...
  • jian09
  • jian09
  • 2015年11月18日 17:08
  • 1576

升级glibc到2.14

转载:https://my.oschina.NET/zhangxu0512/blog/262275 今天运行一个例程,出现了/lib64/libc.so.6: version `GLIBC_...
  • mergerly
  • mergerly
  • 2017年08月17日 20:08
  • 227
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:解决'GLIBC_2.14' not found问题时遇到的坑
举报原因:
原因补充:

(最多只允许输入30个字)