hdu 2815 Mod Tree (扩展BSGS)

7 篇文章 0 订阅

Mod Tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6172    Accepted Submission(s): 1544


Problem Description

  The picture indicates a tree, every node has 2 children.
  The depth of the nodes whose color is blue is 3; the depth of the node whose color is pink is 0.
  Now out problem is so easy, give you a tree that every nodes have K children, you are expected to calculate the minimize depth D so that the number of nodes whose depth is D equals to N after mod P.
 

Input
The input consists of several test cases.
Every cases have only three integers indicating K, P, N. (1<=K, P, N<=10^9)
 

Output
The minimize D.
If you can’t find such D, just output “Orz,I can’t find D!”
 

Sample Input
  
  
3 78992 453 4 1314520 65536 5 1234 67
 

Sample Output
  
  
Orz,I can’t find D! 8 20
 

Author
AekdyCoin
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   2814  2809  2447  2810  2811 

题解:扩展BSGS

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<map>
#define LL long long 
using namespace std;
LL a,p,b;
map<LL,LL> mp;
LL quickpow(LL num,LL x)
{
	LL base=num%p; LL ans=1;
	while (x) {
		if (x&1) ans=ans*base%p;
		x>>=1;
	    base=base*base%p;
	}
	return ans;
}
LL gcd(LL x,LL y)
{
	LL r;
	while (y) {
		r=x%y;
		x=y; y=r;
	}
	return x;
}
LL exbsgs(LL a,LL b,LL p)
{
	a%=p; b%=p;
	if (b==1) return 0;
	LL cnt=0,d=1,tmp=1;
	while ((tmp=gcd(a,p))!=1) {
		if (b%tmp) return -1;
		b/=tmp; p/=tmp; cnt++;
		d=d*(a/tmp)%p;
		if (b==d) return cnt;
	}
	LL m=ceil(sqrt(p)); LL ans=b; LL sum=1;
	mp.clear();
	tmp=quickpow(a,m);
	mp[ans]=0;
	for (LL i=1;i<=m;i++) ans=ans*a%p,mp[ans]=i;
    for (int LL i=1;i<=m+1;i++) {
    	d=d*tmp%p;
    	if (mp[d]) {
    		return i*m-mp[d]+cnt;
		}
	}
	return -1;
}
int main()
{
	freopen("a.in","r",stdin);
	while (scanf("%I64d%I64d%I64d",&a,&p,&b)!=EOF) {
		if (b>=p) {
			printf("Orz,I can’t find D!\n");
			continue;
		}
		LL t=exbsgs(a,b,p);
		if (t!=-1) printf("%I64d\n",t);
		else printf("Orz,I can’t find D!\n");
	}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值