POJ 1751 Highways

Highways
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 9681 Accepted: 2731 Special Judge

Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian government is aware of this problem and has already constructed a number of highways connecting some of the most important towns. However, there are still some towns that you can't reach via a highway. It is necessary to build more highways so that it will be possible to drive between any pair of towns without leaving the highway system. 

Flatopian towns are numbered from 1 to N and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All highways (both the original ones and the ones that are to be built) follow straight lines, and thus their length is equal to Cartesian distance between towns. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways. 

The Flatopian government wants to minimize the cost of building new highways. However, they want to guarantee that every town is highway-reachable from every other town. Since Flatopia is so flat, the cost of a highway is always proportional to its length. Thus, the least expensive highway system will be the one that minimizes the total highways length. 

Input

The input consists of two parts. The first part describes all towns in the country, and the second part describes all of the highways that have already been built. 

The first line of the input file contains a single integer N (1 <= N <= 750), representing the number of towns. The next N lines each contain two integers, xi and yi separated by a space. These values give the coordinates of i th town (for i from 1 to N). Coordinates will have an absolute value no greater than 10000. Every town has a unique location. 

The next line contains a single integer M (0 <= M <= 1000), representing the number of existing highways. The next M lines each contain a pair of integers separated by a space. These two integers give a pair of town numbers which are already connected by a highway. Each pair of towns is connected by at most one highway. 

Output

Write to the output a single line for each new highway that should be built in order to connect all towns with minimal possible total length of new highways. Each highway should be presented by printing town numbers that this highway connects, separated by a space. 

If no new highways need to be built (all towns are already connected), then the output file should be created but it should be empty. 

Sample Input

9
1 5
0 0 
3 2
4 5
5 1
0 4
5 2
1 2
5 3
3
1 3
9 7
1 2

Sample Output

1 6
3 7
4 9
5 7
8 3


题目链接:http://poj.org/problem?id=1751


题目大意:有n座城市,用1-n标记,给出每座城市的坐标,然后输入已有的路的数目和每条路的起点、终点城市。求要使每座城市连通,还需要建的路,保证每一条路长度最小。


解题思路:用到并查集和克鲁斯卡尔算法,先构造每座城市间的距离,一共有n(n-1)/2条路,用结构体存储起始城市和城市间的距离,按距离从小到大排序,已有通路的城市按通路从小到大合并。没有和并的城市合并,并输出起始城市,当路径数目为n-1时结束。


代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=755;
int fa[755];
int xx[755],yy[755];
struct A
{
    int x,y;
	int w;
}eg[maxn*maxn/2];
int find(int x)
{
    return x==fa[x]?x:fa[x]=find(fa[x]);
}
void Union(int a,int b)
{
    int a1=find(a);
    int b1=find(b);
    if(a1!=b1)
		fa[a1]=b1;
}
int cmp(A a,A b)
{
    return a.w<b.w;
}
int main()
{
    int n,m,a,b,j,i;
    scanf("%d",&n);
    for(i=1;i<=n;i++)
    {
        fa[i]=i;
        scanf("%d%d",&xx[i],&yy[i]);
    }
	int cnt=0;
	for(i=1;i<n;i++)
		for(j=i+1;j<=n;j++)
		{
			eg[++cnt].x=i;
			eg[cnt].y=j;
			eg[cnt].w = ((xx[i]-xx[j])*(xx[i]-xx[j])+(yy[i]-yy[j])*(yy[i]-yy[j]));
		}
    sort(eg+1,eg+cnt+1,cmp);
    scanf("%d",&m);
	cnt=0;
    for(i=0;i<m;i++)
    {
        scanf("%d%d",&a,&b);
		if(find(a)!=find(b))
		{
			Union(a,b);
			cnt++;
		}
    }
    for(i=1;i<maxn*maxn/2;i++)
    {
        if(find(eg[i].x)!=find(eg[i].y))
        {
			cnt++;
            Union(eg[i].x,eg[i].y);
            printf("%d %d\n",eg[i].x,eg[i].y);
        }
		if(cnt==n-1)break;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值