hdu 1317 XYZZY (负权回路问题,SPAF实现)

XYZZY

                                                    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                                                        Total Submission(s): 3538    Accepted Submission(s): 987



Problem Description
It has recently been discovered how to run open-source software on the Y-Crate gaming device. A number of enterprising designers have developed Advent-style games for deployment on the Y-Crate. Your job is to test a number of these designs to see which are winnable.
Each game consists of a set of up to 100 rooms. One of the rooms is the start and one of the rooms is the finish. Each room has an energy value between -100 and +100. One-way doorways interconnect pairs of rooms.

The player begins in the start room with 100 energy points. She may pass through any doorway that connects the room she is in to another room, thus entering the other room. The energy value of this room is added to the player's energy. This process continues until she wins by entering the finish room or dies by running out of energy (or quits in frustration). During her adventure the player may enter the same room several times, receiving its energy each time.
 

Input
The input consists of several test cases. Each test case begins with n, the number of rooms. The rooms are numbered from 1 (the start room) to n (the finish room). Input for the n rooms follows. The input for each room consists of one or more lines containing:

the energy value for room i
the number of doorways leaving room i
a list of the rooms that are reachable by the doorways leaving room i
The start and finish rooms will always have enery level 0. A line containing -1 follows the last test case.
 

Output
In one line for each case, output "winnable" if it is possible for the player to win, otherwise output "hopeless".
 

Sample Input
  
  
5 0 1 2 -60 1 3 -60 1 4 20 1 5 0 0 5 0 1 2 20 1 3 -60 1 4 -60 1 5 0 0 5 0 1 2 21 1 3 -60 1 4 -60 1 5 0 0 5 0 1 2 20 2 1 3 -60 1 4 -60 1 5 0 0 -1
 

Sample Output
  
  
hopeless hopeless winnable winnable
 

Source

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1317

题目大意:已知n个点和每条路,第 i 行输入第 i 个点到下一点的边权值,后面输入到达的点。起点 1 处有能量100,每通过一条路,能量加上边权,如果在中途或到达终点n时能量小于等于0,则失败,否则成功。

解题思路:负权值的最短路问题。这题反过来,边权越大越好,注意判断正环,如果存在一个回路是能量不断增大,就设到达这一点的能量是正无穷的,然后继续往终点走。注意,如果在中途能量就小于等于0,算失败。

代码如下:

#include <cstdio>
#include <cstring>
#include <vector>
#include <queue>
#define inf 1e9
using namespace std;
int const maxn=105;
int n;
int dist[maxn],vis[maxn],num[maxn];  //dist记录最大能量值,vis标记点是否访问过,num用来判断正环
struct node    						 //记录边权和后顶点
{
	int v,w;
	node(int vv,int ww)
	{
		v=vv;
		w=ww;
	}
};
vector <node> vt[maxn];
void SPAF(int v0)
{
	memset(vis,0,sizeof(vis));    
	memset(num,0,sizeof(num));
	memset(dist,0,sizeof(dist));
	queue <int>q;
	q.push(v0);
	dist[v0]=100;               //起点能量是100
	while(!q.empty())
	{
		int u=q.front();
		q.pop();
		if(num[u]>n)            //说明有正环,不必再进入环中
			continue;
		num[u]++;
		vis[u]=0;
		int len=vt[u].size();         
		if(num[u]==n+1)        //有正环时把能量记为正无穷
			dist[u]=inf;
		for(int i=0;i<len;i++)
		{
			int v=vt[u][i].v;
			int w=vt[u][i].w;
			if(dist[v]<dist[u]+w&&dist[u]+w>0)    //能量要大于0才能继续前进
			{
				dist[v]=dist[u]+w;
				if(v==n)               			  //如果到达终点,返回
					return;
				if(!vis[v])                       //注意这个标记和压入的位置在这个点能通行的条件下
				{
					vis[v]=1;
					q.push(v);
				}
			}
		}
	}
}
int main(void)
{
	int m,v,w;
	while(scanf("%d",&n)!=EOF&&n!=-1)
	{
		for(int i=0;i<maxn;i++)
			vt[i].clear();
		for(int i=1;i<=n;i++)
		{
			scanf("%d%d",&w,&m);
			for(int j=0;j<m;j++)
			{
				scanf("%d",&v);
				vt[i].push_back(node(v,w));
			}
		}
		SPAF(1);
		if(dist[n]>0)
			printf("winnable\n");
		else
			printf("hopeless\n");
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值