hdu 2795 Billboard(线段树单点更新)

Billboard

                                               Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15595    Accepted Submission(s): 6571



Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 

Sample Input
  
  
3 5 5 2 4 3 3 3
 

Sample Output
  
  
1 2 1 3 -1
 

Author
hhanger@zju
 

Source

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2795

题目大意:每张广告都是高度为1宽度为w的细长的矩形纸条。贴广告的人总是会优先选择最上面的位置来帖,而且在所有最上面的可能位置中,他会选择最左面的位置,而且不能把已经贴好的广告盖住。 如果没有合适的位置了,那么这张广告就不会被贴了。

 现在已知广告牌的尺寸和每张广告的尺寸,求每张广告被贴在的行编号。

解题思路:线段树单点更新。要特别注意h和n的关系,h是广告牌的高度,即线段树的容量,但n上界远远小于h,如果容量直接取h会RE,因此容量应取n和h的较小值。初始化所有节点为w,即每行能贴纸条的宽度。取区间最大值,即该高度区间里能贴纸条的最大宽度,如果该区间最大值小于当前纸条宽度,则不必再访问该区间。

代码如下:
#include <cstdio>
#include <cstring>
#include <algorithm>
#define ll long long
using namespace std;
int const maxn=800005;
int tr[maxn];
int h,w,p;
void Query(int l,int r,int x,int root)
{
	if(l==r)  //线段树的结构特点就是单点从前往后的,即高度是从上往下的
	{
		if(tr[root]-x>=0)   //此行可以贴纸条,更新单点
		{
			tr[root]-=x;
			printf("%d\n",l);
			p=1;           //标记已贴过纸条
		}
		return ;
	}
	int mid=(l+r)/2;
	if(!p&&x<=tr[root*2])
		Query(l,mid,x,root*2);
	if(!p&&x<=tr[root*2+1])
		Query(mid+1,r,x,root*2+1);
	tr[root]=max(tr[root*2+1],tr[root*2]);
}
int main(void)
{
	int x,n;
	while(scanf("%d%d%d",&h,&w,&n)!=EOF)
	{
		h=h>n?n:h;  //不加这句会RE
		for(int i=0;i<maxn;i++)
			tr[i]=w;
		for(int i=0;i<n;i++)
		{
			p=0;
			scanf("%d",&x);
			if(tr[1]<x)
				printf("-1\n");
			else
				Query(1,h,x,1);
		}
	}
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 适合毕业设计、课程设计作业。这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。 所有源码均经过严格测试,可以直接运行,可以放心下载使用。有任何使用问题欢迎随时与博主沟通,第一时间进行解答!

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值