HDU2795 Billboard 线段树 单点更新

Problem Description

At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that’s why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.

Input

There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.

Output

For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can’t be put on the billboard, output “-1” for this announcement.

Sample Input

3 5 5
2
4
3
3
3

Sample Output

1
2
1
3
-1

解题思路

把整块板子竖过来看,每个列(原来的行)的长度就是线段树的初始值。这里注意数据其实取n的最大值就行了,因为大于n的height是没有意义的。线段树维护区间上最大的剩余空间。
update和query都放在了query里。注意query中递归应该在维护之前,而不应该直接return!

代码

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 200010;
int segTree[maxn<<2];
int n,height,width;
void build(int l,int r,int node)
{
    if(l == r) {
        segTree[node] = width;
        return;
    }
    build((l+r)/2+1,r,(node<<1)+1);
    build(l,(l+r)/2,node<<1);
    segTree[node] = max(segTree[node<<1],segTree[(node<<1)+1]);
}
int query(int x,int l,int r,int node)
{
    if(l == r) {
        if(segTree[node] >= x) {
            segTree[node] -= x;
            return l;
        }else return -1;
    }
    int tmp;
    if(x <= segTree[node<<1]) tmp = query(x,l,(l+r)/2,node<<1);
    else tmp = query(x,(l+r)/2+1,r,(node<<1)+1);
    segTree[node] = max(segTree[node<<1],segTree[(node<<1)+1]);
    return tmp;
}
int main()
{
    while(scanf("%d%d%d",&height,&width,&n) != EOF) {
        height = min(height,n);
        build(1,height,1);
        while(n--) {
            int a;
            scanf("%d",&a);
            printf("%d\n",query(a,1,height,1));
        }
    }
    return 0;
}
  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值