HDU 1029 Ignatius and the Princess IV(动规水题,有个很精妙的快解法)

Ignatius and the Princess IV


Time Limit:1000MS    Memory Limit:32767KB    64bit IO Format:%I64d & %I64u

Description

"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which
 integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will 
be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?
 

Input

The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) 
which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is 
terminated by the end of file.
 

Output

For each test case, you have to output only one line which contains the special number you have found.
 

Sample Input

     
     
5 1 3 2 3 3 11 1 1 1 1 1 5 5 5 5 5 5 7 1 1 1 1 1 1 1
 

Sample Output

     
     
3 5 1
 
>>AC代码:
/*
多元素即在数列中出现次数多于n/2的元素

我们很容易的看出来,在一个序列中如果去掉2个不同的元素,
那么原序列中的多元素,在新的序列中还是多元素,
因此我们只要按照序列依次扫描,先把t赋值给result,
增加个计数器,cnt = 1;然后向右扫描,
如果跟result相同,则cnt++,不同,那么cnt --,
这个真是我们从上面那个结论里得出的,一旦cnt == 0了,
那么必定c不是多元素,这个时候把t赋值为result,cnt = 1;,
重复该过程,知道结束,这个时候,result就是多元素,
这个的时间复杂度为n,该题本来可以用数组保存每个元素,
然后递归上述过程,可是,用数组超内存,
因此我们可以直接按照上述过程计算

*/

//注意,用cin,cout会超时
#include<iostream>
#include<string.h>
using namespace std;


int main()
{
    int n,i;
    int t;
    int cnt;
    int result;
    while(scanf("%d",&n)!=EOF)
    {
        cnt=0;
        for(i=0;i<n;i++)
        {
            scanf("%d",&t);
            
            if(cnt==0)
                {
                    cnt=1;
                    result=t;
                }
            else
                {
                    if(t==result)cnt++;
                    else cnt--;
                }        
                
        }
        printf("%d\n",result);    
    }  
    return 0;  
} 

 
    
 
    
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值