杭电OJ 1029 暴力解除 合理利用数组 避免超时



Problem Description
"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?
 

Input
The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.
 

Output
For each test case, you have to output only one line which contains the special number you have found.
 

Sample Input
  
  
5 1 3 2 3 3 11 1 1 1 1 1 5 5 5 5 5 5 7 1 1 1 1 1 1 1
 

Sample Output
  
  
3 5 1


原本我的解法是:先把输入的数字存进数组,然后来一个快排(从小到大),之后取当前集合的(i-1)/2位置的元素输出就好了。

不过超时了。。。


暴力解法就是每个输入的数直接作为数组下标,数组元素就是这个数字出现的次数


比较我的和暴力解法,发现我的解法不但需要跟多空间,还需要更多时间来快排,所以暴力解法可以AC,而我的不行。


总之,代码对付超时时间,还要在数组上多想一想了。



代码

#include <iostream>
#include <algorithm>
using namespace std;

int N[999999];

bool Less(int A,int B)
{
	return A>B;
}

int main()
{
	
	int n;
	int i=0;
	while(cin>>n)
	{
		memset(N,0,sizeof(N));
		i=0;
		int mask=0;
		int temp=(n+1)/2;
		int num;
		while(n--)
		{
			cin>>num;
			N[num]++;
			if(N[num]>=temp)
			{
				mask=num;
			}
		}
		cout<<mask<<endl;
	}




}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 4
    评论
评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值