hdu 1029 Ignatius and the Princess IV 很简单的一道题。

Ignatius and the Princess IV,链接点这里。

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32767 K (Java/Others)
Total Submission(s): 26013 Accepted Submission(s): 10993

Problem Description

“OK, you are not too bad, em… But you can never pass the next test.” feng5166 says.

“I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers.” feng5166 says.

“But what is the characteristic of the special integer?” Ignatius asks.

“The integer will appear at least (N+1)/2 times. If you can’t find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha…..” feng5166 says.

Can you find the special integer for Ignatius?

Input

The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.

Output

For each test case, you have to output only one line which contains the special number you have found.

Sample Input

5
1 3 2 3 3
11
1 1 1 1 1 5 5 5 5 5 5
7
1 1 1 1 1 1 1

Sample Output

3
5
1

Author

Ignatius.L

Recommend

We have carefully selected several similar problems for you: 1074 1171 1203 1114 1069

在做dp专题的时候原本以为这道题是一道Dp,但是看了半天,不知道dp怎么用,倒是觉得是一道挺简单的题。

题意:给你一个整数n,然后是n个整数,求其中的整数中出现次数至少为(n+1)/2 的一个数,输出。

做法:sort一下,然后遍历一遍,找出现个数至少为(n+1)/2的数就ok。


#include<stdio.h>
#include<algorithm>
const int maxn = 1000000;
using namespace std;
int a[maxn];//存数组;
int main()
{
    int t;
    while(~scanf("%d",&t))
    {
        for(int i=0;i<t;i++)
            scanf("%d",&a[i]);//接受数据;

        sort(a,a+t);//排序;

        int flag=a[0],b=1;
        // flag 记录的是当前的数字,初始化为最小的a[0];
        // b 记录当前数组出现的个数;

        for(int i=1;i<t;i++)
        {
            if(a[i]==flag)//判断是否相同;
                b++;   //个数;
            else
            {
                //如果符合情况,跳出;
                if(b>=(t+1)/2)
                    break;

                //否则就重置次数,将当前数字赋值给 flag ;
                b=0;
                flag=a[i];
            }
        }
        printf("%d\n",flag);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值