A Mini Locomotive(01背包题目2)

A Mini Locomotive
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 2429 Accepted: 1352

Description

A train has a locomotive that pulls the train with its many passenger coaches. If the locomotive breaks down, there is no way to pull the train. Therefore, the office of railroads decided to distribute three mini locomotives to each station. A mini locomotive can pull only a few passenger coaches. If a locomotive breaks down, three mini locomotives cannot pull all passenger coaches. So, the office of railroads made a decision as follows:

1. Set the number of maximum passenger coaches a mini locomotive can pull, and a mini locomotive will not pull over the number. The number is same for all three locomotives.
2. With three mini locomotives, let them transport the maximum number of passengers to destination. The office already knew the number of passengers in each passenger coach, and no passengers are allowed to move between coaches.
3. Each mini locomotive pulls consecutive passenger coaches. Right after the locomotive, passenger coaches have numbers starting from 1.

For example, assume there are 7 passenger coaches, and one mini locomotive can pull a maximum of 2 passenger coaches. The number of passengers in the passenger coaches, in order from 1 to 7, is 35, 40, 50, 10, 30, 45, and 60.

If three mini locomotives pull passenger coaches 1-2, 3-4, and 6-7, they can transport 240 passengers. In this example, three mini locomotives cannot transport more than 240 passengers.

Given the number of passenger coaches, the number of passengers in each passenger coach, and the maximum number of passenger coaches which can be pulled by a mini locomotive, write a program to find the maximum number of passengers which can be transported by the three mini locomotives. 

Input

The first line of the input contains a single integer t (1 <= t <= 11), the number of test cases, followed by the input data for each test case. The input for each test case will be as follows:
The first line of the input file contains the number of passenger coaches, which will not exceed 50,000. The second line contains a list of space separated integers giving the number of passengers in each coach, such that the i th number of in this line is the number of passengers in coach i. No coach holds more than 100 passengers. The third line contains the maximum number of passenger coaches which can be pulled by a single mini locomotive. This number will not exceed 1/3 of the number of passenger coaches.

Output

There should be one line per test case, containing the maximum number of passengers which can be transported by the three mini locomotives.

Sample Input

1
7
35 40 50 10 30 45 60
2

Sample Output

240
http://blog.csdn.net/shuangde800/article/details/8955032
#include<iostream>
#include<queue>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<map>
#include<string>
#define MP make_pair
#define SQ(x) ((x)*(x))
//思路:

//因为m<=N/3, 所以按照贪心的思想,为了拉更多的人,每个火车头一定是要拉m个连续的车厢。

//然后,为了求某段连续的车厢共有多少人,可以前缀和预处理, 某一段和=sum[ i ] - sum[ i-m].

//f[i][j] 代表前i个车厢,用j个火车头拉,最多能拉多少人。

//对于第i个车厢,如果当前这个车头选择要拉这个车厢,那么要把以i为最后一个车厢的连续m个车厢一起拉,所以状态转移方程是:

f[i][j] = max(f[i-1][j], f[i-m][j-1]+sum[i]-sum[i-m]);


using namespace std;
typedef long long int64;

const double PI = acos(-1.0);  //截获PI的值!!! 
const int MAXN = 50010;
const int INF = 0x3f3f3f3f;
int n, m;
int w[MAXN], sum[MAXN];
int f[MAXN][4];


int main(){

    int nCase;              // 案例个数 
    scanf("%d", &nCase);
    while(nCase--){
        scanf("%d", &n);            // 火车有几节 

        for(int i=1; i<=n; ++i){
            scanf("%d", &w[i]);           // w[i]用来存每节火车里面有的人数 
            sum[i] = sum[i-1] + w[i];        // 前i节车厢里面一共有多少人 
        }

        scanf("%d", &m);       //  最多可以推动几节火车 

        memset(f, 0, sizeof(f));
        
        for(int i=m; i<=n; ++i){
            for(int j=3; j>=1; --j){
                f[i][j] = max(f[i-1][j], f[i-m][j-1]+sum[i]-sum[i-m]);   f[i][j] 代表前i个车厢,用j个火车头拉,最多能拉多少人。
                              // 不要第i个车厢    // 前i-m个车厢用j-1个车头来拉+后m个车厢有的人数 
            }
        }
          
        printf("%d\n", f[n][3]);
    }
    return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值