poj2777Count Color(线段树)

Count Color
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 40404 Accepted: 12188

Description

Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem. 

There is a very long board with length L centimeter, L is a positive integer, so we can evenly divide the board into L segments, and they are labeled by 1, 2, ... L from left to right, each is 1 centimeter long. Now we have to color the board - one segment with only one color. We can do following two operations on the board: 

1. "C A B C" Color the board from segment A to segment B with color C. 
2. "P A B" Output the number of different colors painted between segment A and segment B (including). 

In our daily life, we have very few words to describe a color (red, green, blue, yellow…), so you may assume that the total number of different colors T is very small. To make it simple, we express the names of colors as color 1, color 2, ... color T. At the beginning, the board was painted in color 1. Now the rest of problem is left to your. 

Input

First line of input contains L (1 <= L <= 100000), T (1 <= T <= 30) and O (1 <= O <= 100000). Here O denotes the number of operations. Following O lines, each contains "C A B C" or "P A B" (here A, B, C are integers, and A may be larger than B) as an operation defined previously.

Output

Ouput results of the output operation in order, each line contains a number.

Sample Input

2 2 4
C 1 1 2
P 1 2
C 2 2 2
P 1 2

Sample Output

2
1

Source


题意:一条很长(L)的画板,有T种颜色,O个操作;每次操作将一个区间刷成一种颜色,或者查询一个区间内所含的颜色数。
分析:这题和hud1698很像,就查询有所不同,具体看代码和 HDU1698

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int MOD = 1000000007;
#define ll long long
#define CL(a,b) memset(a,b,sizeof(a))
#define MAXN 100010

struct node
{
    int l,r,s;
} t[MAXN<<2];
int L,O,T;
int sum[33];//因为颜色数不多,可以用一个数组来装;1表示该区间有该颜色,0反之

void build(int l, int r, int i)
{
    t[i].l = l;
    t[i].r = r;
    t[i].s = 1;
    if(l == r) return ;
    int mid = (l+r)>>1;
    build(l, mid, i<<1);
    build(mid+1, r, i<<1|1);
}

void update(int l, int r, int m, int i)
{
    if(t[i].s == m) return ;
    if(t[i].l == l && t[i].r == r)
    {
        t[i].s = m;
        return ;
    }
    if(t[i].s != -1)
    {
        t[i<<1].s = t[i<<1|1].s = t[i].s;
        t[i].s = -1;
    }
    int mid = (t[i].l+t[i].r)>>1;
    if(l > mid) update(l, r, m, i<<1|1);
    else if(r <= mid) update(l, r, m, i<<1);
    else
    {
        update(l, mid, m, i<<1);
        update(mid+1, r, m, i<<1|1);
    }
}

void query(int l, int r, int i)
{
    if(t[i].s != -1)//如果纯色把该颜色标记
    {
        sum[t[i].s] = 1;
        return ;
    }
    else//否则继续查询子节点
    {
        int mid = (t[i].l+t[i].r)>>1;
        if(l > mid) query(l, r, i<<1|1);
        else if(r <= mid) query(l, r, i<<1);
        else
        {
            query(l, mid, i<<1);
            query(mid+1, r, i<<1|1);
        }
    }
}

int main()
{
    char ch;
    int a,b,c;
    while(scanf("%d%d%d",&L,&T,&O)==3)
    {
        build(1, L, 1);
        while(O--)
        {
            getchar();
            scanf("%c",&ch);
            if(ch == 'C')
            {
                scanf("%d%d%d",&a,&b,&c);
                update(a, b, c, 1);
            }
            int ans = 0;
            if(ch == 'P')
            {
                CL(sum, 0);//每次查询之前清零
                scanf("%d%d",&a,&b);
                query(a, b, 1);
                for(int i=1; i<=T; i++)//统计出现过的颜色数
                    if(sum[i]) ans++;
                printf("%d\n",ans);
            }
        }
    }
    return 0;
}


  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值