poj3140 Contestants Division(树形dp)

Contestants Division
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 9004 Accepted: 2583

Description

In the new ACM-ICPC Regional Contest, a special monitoring and submitting system will be set up, and students will be able to compete at their own universities. However there’s one problem. Due to the high cost of the new judging system, the organizing committee can only afford to set the system up such that there will be only one way to transfer information from one university to another without passing the same university twice. The contestants will be divided into two connected regions, and the difference between the total numbers of students from two regions should be minimized. Can you help the juries to find the minimum difference?

Input

There are multiple test cases in the input file. Each test case starts with two integers N and M, (1 ≤ N ≤ 100000, 1 ≤ M ≤ 1000000), the number of universities and the number of direct communication line set up by the committee, respectively. Universities are numbered from 1 to N. The next line has N integers, the Kth integer is equal to the number of students in university numbered K. The number of students in any university does not exceed 100000000. Each of the following M lines has two integers st, and describes a communication line connecting university s and university t. All communication lines of this new system are bidirectional.

N = 0, M = 0 indicates the end of input and should not be processed by your program.

Output

For every test case, output one integer, the minimum absolute difference of students between two regions in the format as indicated in the sample output.

Sample Input

7 6
1 1 1 1 1 1 1
1 2
2 7
3 7
4 6
6 2
5 7
0 0

Sample Output

Case 1: 1

Source


题意:给定一颗n节点的树,每个结点有k个学生;求删除一条边之后分成的两棵子树的学生数差最小,输出差值。
分析:求出每个结点以自己为根的树的节点数,然后用总学生数去减就行了。
Ps:这题真的让我心碎,WA无数遍,但一直找不到错,最后对照着某大牛博客修改,依然WA,最后我烦的很,把所有不一样的全部改了,终于找出了错误,(见代码)然而我并不知道为什么。如果你知道的话,请告诉我,please!

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
#define INF 21474836470000000
//const int INF = 0x3f3f3f3f;   //提交到心碎,结果是这里的问题
const int MOD = 1000000007;
#define ll long long
#define CL(a,b) memset(a,b,sizeof(a))
#define MAXN 200010
#define JJ(a)  (a<0?-a:a)
#define min(a,b) (a)<(b)?(a):(b)

struct node
{
    int v;
    node *next;
}tree[MAXN], *head[MAXN];
int n,m,pre,num[MAXN],vis[MAXN];
ll ans,dp[MAXN],sum;

void init()
{
    sum = 0;
    pre = 1;
    ans = INF;
    CL(vis, 0);
    CL(head, NULL);
}

void add(int x, int y)
{
    tree[pre].v = y;
    tree[pre].next = head[x]; head[x] = &tree[pre++];
    tree[pre].v = x;
    tree[pre].next = head[y]; head[y] = &tree[pre++];
}

void dfs(int son, int father)//求出每个结点为根包含的学生数
{
    dp[son] = num[son];
    vis[son] = 1;
    node *p = head[son];
    while(p != NULL)
    {
        if(vis[p->v] == 0)
        {
            dfs(p->v, son);
            dp[son] += dp[p->v];
        }
        p = p->next;
    }
}

void dp_tree()//直接暴力求就行了
{
    for(int i=1; i<=n; i++)
    {
        ll tp = dp[i];
        ans = min(ans, JJ((2*tp-sum)));
    }
}

int main()
{
    int a,b,cas=1;
    while(scanf("%d%d",&n,&m),n+m)
    {
        init();
        for(int i=1; i<=n; i++)
            scanf("%d",&num[i]), sum += num[i];
        for(int i=1; i<=m; i++)
        {
            scanf("%d%d",&a,&b);
            add(a, b);
        }
        dfs(1, 0);
        CL(vis, 0);
        dp_tree();
        printf("Case %d: %I64d\n",cas++,ans);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值