hdu1698 Just a Hook(线段树)

Just a Hook

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 24473 Accepted Submission(s): 12193


Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.

Sample Input
  
  
1 10 2 1 5 2 5 9 3

Sample Output
  
  
Case 1: The total value of the hook is 24.

Source

题意:一段线段由n条小线段组成,每次操作把一个区间的小线段变成金银铜之一(金的价值为3,银为2,铜为1),最初可当做全为铜;最后求这条线段的总价值。
分析:基础的区间更新,我也是刚学,按照我的理解区间更新就是,树最开始有个状态,然后每次更新就相当于把一个节点为根节点的树全部变成同一种状态;也就是每个结点有个数,表示以该结点为根结点的树的所有结点都是这个数,或者表示以该结点为根的树有不同数,那么就把他变为-1(或者其他,你开心就好),然后再往下处理。不知道能不能看懂,真的不太好描述- -。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int MOD = 1000000007;
#define ll long long
#define CL(a,b) memset(a,b,sizeof(a))
#define MAXN 100000+10

struct node
{
    int l,r,s;
}t[MAXN<<2];
int n,sum;

void build(int l, int r, int num)
{
    t[num].l = l;
    t[num].r = r;
    t[num].s = 1;
    if(l == r) return ;
    int mid = (l+r)>>1;
    build(l, mid, num<<1);
    build(mid+1, r, num<<1|1);
}

void update(int l, int r, int m, int num)
{
    if(t[num].s == m) return ;//如果是相同的,就不用改了
    if(t[num].l == l && t[num].r == r)//
    {
        t[num].s = m;
        return ;
    }
    if(t[num].s != -1)//该区间只有一种颜色
    {
        t[num<<1].s = t[num<<1|1].s = t[num].s;//把他的所有子节点变为父结点一样的颜色
        t[num].s = -1;//由于该区域颜色与修改不同,所以该区域由纯色变为杂色  
    }
    //父区间为杂色对所有子节点进行处理
    int mid = (t[num].l+t[num].r)>>1;
    if(l > mid)
        update(l, r, m, num<<1|1);
    else if(r <= mid)
        update(l, r, m, num<<1);
    else
    {
        update(l, mid, m, num<<1);
        update(mid+1, r, m, num<<1|1);
    }
}

int query(int num)
{
    if(t[num].s != -1)//纯色直接找
        return (t[num].r-t[num].l+1)*t[num].s;
    else//不纯就找左右子树
        return query(num<<1)+query(num<<1|1);
}

int main()
{
    int x,y,z,T,k;
    int cas = 1;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&k);
        build(1, n, 1);
        while(k--)
        {
            scanf("%d%d%d",&x,&y,&z);
            update(x, y, z, 1);
        }
        printf("Case %d: The total value of the hook is %d.\n",cas++,query(1));
    }
    return 0;
}


  • 1
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值