ZOJ 3537 Cake(凸包判定+区间DP)

Cake
Time Limit: 1 Second Memory Limit: 32768 KB
You want to hold a party. Here’s a polygon-shaped cake on the table. You’d like to cut the cake into several triangle-shaped parts for the invited comers. You have a knife to cut. The trace of each cut is a line segment, whose two endpoints are two vertices of the polygon. Within the polygon, any two cuts ought to be disjoint. Of course, the situation that only the endpoints of two segments intersect is allowed.

The cake’s considered as a coordinate system. You have known the coordinates of vexteces. Each cut has a cost related to the coordinate of the vertex, whose formula is costi, j = |xi + xj| * |yi + yj| % p. You want to calculate the minimum cost.

NOTICE: input assures that NO three adjacent vertices on the polygon-shaped cake are in a line. And the cake is not always a convex.

Input

There’re multiple cases. There’s a blank line between two cases. The first line of each case contains two integers, N and p (3 ≤ N, p ≤ 300), indicating the number of vertices. Each line of the following N lines contains two integers, x and y (-10000 ≤ x, y ≤ 10000), indicating the coordinate of a vertex. You have known that no two vertices are in the same coordinate.

Output

If the cake is not convex polygon-shaped, output “I can’t cut.”. Otherwise, output the minimum cost.

Sample Input

3 3
0 0
1 1
0 2
Sample Output

0

首先得判定一下这些点是否可以构成凸包,只要用凸包算法看看这些点构成的凸包的顶点的个数是否等于n。凸包判定直接参考大牛的博客,模板
http://blog.csdn.net/woshi250hua/article/details/7824433
写区间DP的时候注意循环的顺序

关于区间DP,可以参照这个博客
http://blog.csdn.net/dacc123/article/details/50885903

#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>
#include <stdio.h>

using namespace std;
#define MAX 100000000
int n,p;
struct Node
{
    int x,y;
}a[400];
int s[400];
int cos1[400][400];
int dp[400][400];
int top;
int cross(Node a,Node b,Node c)
{
    return (b.x-a.x)*(c.y-a.y)-(b.y-a.y)*(c.x-a.x);
}
int dis(Node a,Node b)
{
    return sqrt((double)(a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
int cmp(Node p1,Node p2)
{
    int temp=cross(a[0],p1,p2);
    if(temp>0) return true;
    else if(temp==0&&dis(a[0],p1)<dis(a[0],p2)) return true;
    else return false;
}
int graham(int n)
{
    if(n==1){return 0;}
    if(n==2){return 1;}
    if(n>2)
    {
        top=1;s[0]=0;s[1]=1;
        for(int i=2;i<n;i++)
        {
            while(top>0&&cross(a[s[top-1]],a[s[top]],a[i])<=0)
                top--;
            s[++top]=i;
        }
        return top;
    }

}
int cost(Node a,Node b)
{
    return abs(a.x+b.x)*abs(a.y+b.y)%p;
}
int main()
{
    while(scanf("%d%d",&n,&p)!=EOF)
    {
        scanf("%d%d",&a[0].x,&a[0].y);
        for(int i=1;i<n;i++)
        {
            scanf("%d%d",&a[i].x,&a[i].y);
            if(a[i].y<a[0].y||(a[i].y==a[0].y&&a[i].x<a[0].x))
            {
                swap(a[i],a[0]);
            }
        }
        sort(a+1,a+n,cmp);
        if(graham(n)!=n-1)
        {
            printf("I can't cut.\n");
            continue;
        }
        for(int i=0;i<n;i++)
        {
            for(int j=i+2;j<n;j++)
                cos1[i][j]=cos1[j][i]=cost(a[i],a[j]);
        }
        for(int i=0;i<n;i++)
        {
            for(int j=i;j<n;j++)
                dp[i][j]=MAX;
            dp[i][(i+1)%n]=0;
        }
        for(int i=n-3;i>=0;i--)
        {
            for(int j=i+2;j<n;j++)
            {
                for(int k=i+1;k<j;k++)
                {
                    dp[i][j]=min(dp[i][j],dp[i][k]+dp[k][j]+cos1[i][k]+cos1[k][j]);
                }
            }
        }
        printf("%d\n",dp[0][n-1]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值