HDU 5762 Teacher Bo (水题)

题目链接:HDU 5762


题面:

Teacher Bo

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 644    Accepted Submission(s): 353


Problem Description
Teacher BoBo is a geography teacher in the school.One day in his class,he marked N points in the map,the i -th point is at (Xi,Yi) .He wonders,whether there is a tetrad (A,B,C,D)(A<B,C<D,ACorBD) such that the manhattan distance between A and B is equal to the manhattan distance between C and D.

If there exists such tetrad,print "YES",else print "NO".
 

Input
First line, an integer T . There are T test cases. (T50)

In each test case,the first line contains two intergers, N, M, means the number of points and the range of the coordinates. (N,M105) .

Next N lines, the i -th line shows the coordinate of the i -th point. (Xi,Yi)(0Xi,YiM) .
 

Output
T lines, each line is "YES" or "NO".
 

Sample Input
  
  
2 3 10 1 1 2 2 3 3 4 10 8 8 2 3 3 3 4 4
 

Sample Output
  
  
YES NO
 

Source


题意:

     问给定的点中,是否存在两对点的曼哈顿距离完全相同,两对点不可以是同一对点。


解题:

     其实这题考察的就是暴力,只要抓住差值范围是在0-2*10^5范围内这一点就可以解决。看似n^2遍历,实则最多只会在2*10^5时停下来,用vis数组标记一下即可,如果出现点访问两次即有。


代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <string>
#include <cstring>
#include <cmath>
#define LL long long
using namespace std;
bool vis[200005];
int x[100005],y[100005];
int main()
{
	int t,n,m,tmp;
	bool flag=0;
	scanf("%d",&t);
	while(t--)
	{
	  flag=0;
	  scanf("%d%d",&n,&m);
	  memset(vis,0,sizeof(vis));
	  for(int i=0;i<n;i++)
		  scanf("%d%d",&x[i],&y[i]);
	  for(int i=0;i<n;i++)
	  {
		  for(int j=i+1;j<n;j++)
		  {
			  tmp=abs(x[j]-x[i])+abs(y[j]-y[i]);
			  if(vis[tmp])
			  {
				  flag=1;
				  break;
			  }
			  else
				  vis[tmp]=1;
		  }
		  if(flag)break;
	  }
	  if(flag)printf("YES\n");
	  else printf("NO\n");
	 }
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值